Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

rookie1082
Advisor

GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

Hello,

***I have tried the following scenario using both ADK 8.1 and 10.0***


I created a Winpe Bootable disk via the HPEBIOS cmdlets.  I then mounted the boot.wim, injected the drivers that were in the STK 11.05 folder (WinPE Version specific).  A total of 32 drivers were successfully injected.

I then transferred the tools folder over that contains conrep, hpnpcfg, ilorest, etc.  This was also part of STK 11.05.

i commit the DISM changes, i recompile my iso.  I mount the ISO via ILO on a Gen10 server and boot to WinPE.

Startnet loads the CHIF and CORE drivers per normal, i then try running conrep.  Conrep uses by default the Gen10.XML file, but does not do anything after "MATCHING" the Server Model.

It doesn't save the configuration using "Conrep -s -f X:\temp.dat"

Also, if i try to load, I get a Memory referenced error from Conrep -l

 

HPONCFG:

Says ILO drivers need to be loaded eventhough the CHIF and CORE drivers are loaded by startnet.  Am i missing something here?

Let me know if you need any more info.

4 REPLIES
GZahidi
Advisor

Re: GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

Hi,

Looks like you are trying to set some of the bios settings using conrep.exe. If my guess is right then you can use HPEBIOSCmdlets to configure bios settings. Use ilo IP, username and password to establish connection and use bios cmdlets.

For Gen10 BIOS Cmdlets use redfish to do the configuration.

rookie1082
Advisor

Re: GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

Thanks GZahidi.


I am curious as to why the newer HPEBIOS cmdlets (specifically creating a custom winpe image) does not work with winpe 5.0 or 10.0.  

I am curious if i'm missing something.  

We have a lot of generation servers (from Gen5 to Gen10) and using conrep/ssascripting/etc via WinPE is the easiest way to keep it all in a nice workflow in our environment.

Can anyone advise as to why the winPE command does not support ILO5 or Gen10 with the newest scripting toolkit drivers?

GZahidi
Advisor

Re: GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

HI,

The WinPE  created by New-HPEBIOSCustomWinPEImage cmdlet is used only for Gen8 servers. Those WinPE images are not qualified for Gen10 servers.

Now in your case you have modified the WInPE image by adding some extra drivers and utility,so  please go through IDSM.exe logs.

And one more thing please verify whether conrep.exe is supported on Gen10 servers or not.

rookie1082
Advisor

Re: GEN10 - Scripting Toolkit v11.05 and WinPE5.0 / 10.0 Errors - CONREP and HPONCFG

GZahidi,

The WinPE that's created using New-HPEBIOSCustomWinPEImage is dependent on the ADK version that is installed on your system.  In my case, I have created both winPE 5.0 and 10.0 images from that HPE Cmdlet.  

The cmdlet may only support "gen8" servers per se, but the final product (WinPE) is supported on all models as long as the correct *.inf files are loaded using drvload.

I am using conrep from the STK 11.05.

I have both winPE 5.0 and 10.0 working fine now.  I added over 30 drivers into the image and got them to talk to the servers.