Server Management - Remote Server Management

Get-HPEiLOServerSoftwareInventory does not return version and process name

 
Anand1202
Collector

Get-HPEiLOServerSoftwareInventory does not return version and process name

I am using Scripting Tools for Windows PowerShell: iLO cmdlets released on 22 Feb 2021 (link: Software Details | HPE Support Center)

[Extra question #1: Why is the latest version not top of the revision list ? ]

I enjoy the information provided by 

(Get-HPEiLOFirmwareInventory -Connection $connection).FirmwareInformation 

I will get info like:

Index : 1
FirmwareName : iLO 5
FirmwareVersion : 2.41 Mar 08 2021
DeviceClass : 2e317b8d-c9f3-4d56-bfe6-b9d1d0850a52
DeviceInstance :
Location : System Board
Targets : {4764a662-b342-4fc7-9ce9-258c5d99e815, c1bcf2b6-1131-49bf-aac8-c73791f0349c}
Status : HPE.iLO.Response.Redfish.Status

That is all good. I can get the info I need on Firmware.

I would also like to use PowerShell to pull info on the HPE Software installed.

But when I run

(Get-HPEiLOServerSoftwareInventory -Connection $connection).ServerSoftwareInfo

I get a result where som data seems to be missing, example:

Index : 1
Description : agentless management service
Name :
Version :
DeviceContext :
DeviceClass : e7a8c7dd-a6c1-4156-b14b-98bc323ddc7b
DeviceInstance :
Targets : {20a6e8e4-bf33-4c71-a6af-d9ec7b303367}

Notice how there is no "Name" and no "Version".

Why is that?

If I log into the iLO 5 I can see name should be ams.exe and version 2.30.1.0. But it does not show when I run the PowerShell command.

[Extra question #2: Why is "ssaducli.exe" named " smart storage administrator" (version 4.21.7.0) ? That name is also used by "ssa.exe" and it is thus difficult to see which is which, they should not be identical - maybe a mistake by the person who entered it somewhere?! - Where? ANd can it be changed?]

 

 

 

1 REPLY 1
Anand1202
Collector

Re: Get-HPEiLOServerSoftwareInventory does not return version and process name

FYI..

 

I tried to downgrade from version 3.1.0.0 to version 3.0.0.1 ( Software Details | HPE Support Center ). [Edit: This version by the way appear as version 3.0.1.0 in Add/Remove Programs on Windows Server 2016 OS]

 

Same issue. I still do not get any data for name and version for the HPE software installed...

 

I wonder if it works for anyone out there.. Eg. if it is some local issue I expereince or if it is a general issue with the PowerShell Module...

 

Edit: If no help is provided in this thread (or in the case opened by HPE to support me addressing this issue) then I plan to find time next month to downgrade iLO 5 firmware to version 2.31 and try to connect directly to see if issue perhaps is caused by new firmware or network/firewall - I will update this thread with my findings).