Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

ILO Configuration using CPQLOCFG.EXE

SOLVED
Go to solution
JoopNL
Advisor

ILO Configuration using CPQLOCFG.EXE

I am trying to configure ILO's with firmware 1.55 using CPQLOCFG.EXE 2.22

The XML Script is like this:















This is modified from the sample scripts.

When i run the following command:

CPQLOCFG.EXE -s aplsrv186rc -f script.xml

the result is:

START_OPEN_TAG
RIB_INFO
MODE
EQUALS
write
END_TAG
START_OPEN_TAG
MOD_SNMP_IM_SETTINGS
END_TAG
CPQLOCFG.EXE: Response received from the RIB: (190):


STATUS="0x0001"
MESSAGE='Syntax error: Line #3: syntax error near "<" in the line: "< MOD_SNMP_IM_SETTINGS >"'
/>


(I cut off the top and bottom of the output. See attached text file for output without word-wrap.)

According to the ILO manual (TPM_238882-004-e.pdf, page 190) the is a valid tag for ILO.

So, I can't figure out the reason for this error. Can anyone help?
3 REPLIES
Chris_557
Occasional Advisor

Re: ILO Configuration using CPQLOCFG.EXE

It sounds like it is upset about a line inside the MOD_SNMP_IM_SETTINGS and not the MOD_SNMP_IM_SETTINGS line itself. Line #3, so it's either the OS TRAPS or the PASTHROUGH setting it doesn't like. I'm not totally familiar with the XML scripts, but general code debugging seems to say this is the case.
Junior Yharte
Trusted Contributor
Solution

Re: ILO Configuration using CPQLOCFG.EXE

I copied your script as you have it entered and ran it against an iLO w/ 1.55 firmware and had no problems. I was also using 2.22 cpqlocfg.exe ... so can you double check your versions and provide any other info about your setup? The one thing that might prompt this error would be if you were trying to run it against an iLO w/ older F/W.
JoopNL
Advisor

Re: ILO Configuration using CPQLOCFG.EXE

I have double checked the versions and I was wrong. In a whole batch of servers I was configuring there was just one with a RILOE II. This was the server wich I ran my script against. (Murphy :( )

When I tried the script on ILO's with 1.55 it actually works just fine. I'm going to investigate now why it won't work on RILOE II. First thing I'm going to look at is if it is even supposed to work or perhaps it just isn't supported on RILOE II.

Chris your reply seems to be correct but I need to look at it. I'll assign points later.

Thanks both.