Server Management - Remote Server Management
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem opening iLO remote sessions

dspent_1
Occasional Visitor

Problem opening iLO remote sessions

I am having an issue (as are 2 others in my office) where any attempt to open an iLO remote session to any of our blade servers regardless of the enclosure type (c7000 or c3000) results in the following behavior:

1. Open Onboard Administrator
2. Expand Device Bays
3. Expand Blade/Server to see iLO options
4. Select any option (for example Integrated Remote Console w/activex or Java based Remote Console - doesn't matter which)
5. A popup window opens with the following text displayed:
The Onboard Administrator is contacting iLO. Please Wait...
6. The remote session is opened in the parent window (the previous window where the onboard administrator console was opened) rather than opening in the newly opened popup.

I cannot figure out why this is occuring. Previously I thought it was just me Internet Explorer settings on my old laptop. However, I just got a brand new HP desktop on Tuesday. The exact same behavior is occurring on it and I have made NO changes to IE or the PC other than turning it on. The only difference between my new system and the old laptop and the system I had before where this DID NOT occur was the system that worked was XP. The laptop and now the new desktop run Windows 7.

Now before we say it's windows 7 as the cause, please know that others do not have this problem in Windows 7. Nor does this problem happen on my Windows 7 system at home that I use to VPN into the corporate network.

Does anyone else experience this issue and have a solution?

My current setup is:

HP Pro 3130
Windows 7 64 Bit SP1
i7 870 @ 2.93Ghz
8GB Ram
IE 8

My Old laptop was:
Dell D630 Laptop
Windows 7 32 Bit
4GB Ram
IE 8
Firefox 3.xxx
Upgraded from working system below.

System that worked fine was:
Same laptop as above with same browsers as above. Except it had Windows XP.
5 REPLIES
Oscar A. Perez
Honored Contributor

Re: Problem opening iLO remote sessions

Could you please post the OA and iLO firmware versions you have?



__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
dspent_1
Occasional Visitor

Re: Problem opening iLO remote sessions

This problem occurs regardless of OA and iLO versions/Firmware. We have several different enclosures... Most of the enclosures are C7000 running 3.11 Aug 19 2010 firmware

The blades themselves are a mix of ilo 2 and 3. This issue occurs on all of them.
Michael Leu
Honored Contributor

Re: Problem opening iLO remote sessions

Maybe try another browser or IE8 in compatibility mode?

By the way, from the OA user guide:
---
The following browsers are supported for use with Onboard Administrator:
- Microsoft Internet Explorer 6.0, 7.0, and 8.0 (in compatibility mode)
- Mozilla Firefox 1.5, 2.0, 3.0, and 3.5.x
- Other browsers can be used, but are not supported.
http://bizsupport2.austin.hp.com/bc/docs/support/SupportManual/c00705292/c00705292.pdf#page=10
---

It's is still strange that your box is the only one that doesn't work with IE 8. Maybe some sort of popup-blocker or anti-cross-site-scripting thing active?
dspent_1
Occasional Visitor

Re: Problem opening iLO remote sessions

Compatibility mode doesn't have any affect and using another browser also doesn't work.

In addition, using another browser is not possible for the integrated remote console option because it requires activeX which is proprietary to IE.

If it weren't for the fact they use javascript to open the remote consoles then I could at least see what URL/File/Page they were calling and HOW they were calling the page. Then I could perhaps troubleshoot exactly what is not happening correctly and fix it. But because the process is so hidden, it's hard to know if it is the browser, the app, the OS etc...
dspent_1
Occasional Visitor

Re: Problem opening iLO remote sessions

I FIXED IT!!!!

I read a post on what turned out to be an unrelated issue, but in that post it talked about how the remote console uses javascript and cookies. The mention of cookies was intriguing so I went to the browser options
Tools - Internet Options - Privacy Tab

There I changed the default setting of MEDIUM for the internet and local intranet zones. Restarted IE and tried to access the console again. This time, it opened the popup and then the remote console opened in the child window like it should.

NOW, what is interesting is - I wanted to be sure of which change fixed the problem, so I set everything back to the way it was. I then tried it again. It still works. So my best guess is there is something downloaded or running in the browser or a cookie that I didn't have before that I now have after the first successful run that wasn't there before that allows the browser to open the console properly rather than in the parent window. Very interesting.

I have gone to my 2 colleagues' desktops and performed the same steps and it has also fixed their issues.

I am posting back the resolution so that any others may also know what we did to resolve.