Server Management - Remote Server Management
Showing results for 
Search instead for 
Did you mean: 

Problem setting iLO static IP


Problem setting iLO static IP

I have 2 DL380 G6 servers that I needed to change the iLO static IP addresses on. I thought it was as straight-forward as interrupting the boot at the iLO prompt and changing it through the menu.

However, on the first server that didn't work. What I eventually had to do was turn on DHCP, cycle power, interrupt again at the iLO config, then turn off DHCP and set the static IP.

Unfortunately, that same process isn't working for the second server... in fact, nothing is working. I even tried resetting iLO back to factory defaults and then setting the static IP, but no luck.

It appears to be picking up the IP that I'm assigning it because it lists the correct one on-screen during startup, but the switch doesn't see any MAC address on that port (and yes I've checked the port, checked the cable, and even tried a different port/cable). I have seen mention of a problem with iLO arp MAC broadcast on these forums but not details on what that is all about.

Thanks in advance for any suggestions/help.
Honored Contributor

Re: Problem setting iLO static IP

Is this the iLO2 dedicated NIC or Shared NIC?

Are you changing the other NIC settings like link speed auto-negotiation?

You should always use AUTO.

If you feel this was helpful please click the KUDOS! thumb below!

Re: Problem setting iLO static IP

It's a dedicated NIC. Everything is set to AUTO.

Strangely enough, it eventually just woke up and started working... and by eventually I mean somewhere between 10 to 30 minutes of it just sitting there idle (server powered off). For whatever reason, the switch saw no initial IP traffic from the iLO port so it didn't pick up the MAC address.