Server Management - Systems Insight Manager
Showing results for 
Search instead for 
Did you mean: 

Re: Trouble setting up HPSIM 7.4

Occasional Visitor

Trouble setting up HPSIM 7.4



I have set up a new server for HPSIM but I've hit something of a brick wall with discovery..

the iLOs and OAs all discover fine, but when I start discovering the windows servers, I am unable to get them properly discovered.


I have updated SMH to the latest version on the server and even tried disabling UAC on both the HPSIM server and the target server, after googling this issue, but I still get this result.


The discovery log from one of the servers:


********* Significant issues and overall target discovery/identification
Major: The system cannot be identified properly for HP SIM to manage;
unable to get one or more of the following: model, serial number or
unique identifier (UUID). For management processors, verify the
system is running the latest firmware. For Linux based operating
systems, you must have dmidecode installed, enable the
PermitRootLogin and PasswordAuthentication in sshd, and use root
credential. For HP-UX, verify the sign-in credential. For
Windows, check if WMIMapper is configured correctly on the CMS and
verify the sign-in credential.
Critical: The system(s) can not be identified by WBEM, SNMP or SSH

********* Additional results (listed for information only):

* Starting identification process...
* Checking for known running web servers...
* Checking for SNMP protocol support on system...
Normal: The system did not respond to SNMP. Verify security settings and
community strings in Options->Security->Credentials->System
* Checking for SNMPv3 protocol support on system...
Normal: The system did not respond to SNMPv3. Verify security settings and
v3 credentials in Options->Security->Credentials->System
* Running HP ProLiant management agent identification...
Normal: The system does not support SNMP.
* Running SNMP base cluster identification using common cluster
Normal: SNMP is not supported or globally disabled, skipping SNMP cluster
* Checking for WBEM protocol support on system...
Minor: This system does not have any SMI-S CIMOMs installed. No storage
systems will be found on this system.
Minor: The Central Management System (CMS) cannot communicate with the
CIMOM locally installed on the managed system using the WBEM
protocol, Identification will try to identify Windows systems using
the WMI Mapper as proxy; for Linux and HP-UX systems, check
credentials by going to Options->Security->Credentials->System
Credentials. For Linux systems also check if the HP WBEM provider
is installed.
* Running WBEM rules based identification...
Minor: Identification cannot get computer system hardware data from the
WBEM / WMI providers.
* Running Virtual Machine (VM) Host (non HP Integrity VM Host)
Normal: The system is not a VM Host (non HP Integrity VM Host), or WBEM
credentials may not be specified so skipping VM Identification.
* Running Storage identification...
* Did not detect the WBEM protocol support on this system. SMI
storage identification will be skipped.
* Storage identification completed.
* Running HP NetServer identification...
Normal: The system does not support SNMP.
* Running HP-UX SNMP identification...
Normal: The system does not support SNMP.
* Running OA Identifier which will discover systems in an enclosure
if the automatic enclosure discovery option for OA is enabled...
Normal: The system is not an Onboard Administrator, skipping automatic
discovery of systems in the enclosure.
* Running XMLReply Identifier which will discover systems in a
rack/enclosure if the automatic discovery option for the container
node is enabled...
* Running iLO Identifier which will discover the server if the
automatic server discovery option for iLO is enabled...
Minor: The system responds to the HTTP request but cannot get the XML
output. It is normal for servers not to get the XML data.
Minor: If the http communication from CMS to target is working, but if it
is found to be slow then try increasing the Default connection
timeout parameter for http in global protocol settings.
* Running p-Class Identifier...
Normal: The system is not a p-Class so skipping p-Class identification.
* Running IPMI protocol identification...
Minor: Running an ipmiutil command failed and the IPMI protocol is not
* Running SSH Protocol identification...
Normal: This system has SSH protocol support.
* Running SSH Identification...
Minor: The system cannot be logged in using SSH protocol; check
credentials or check the settings in the SSH configuration file
* Running WS-Man identification...
Minor: The system did not respond to WS-Management (WS-Man) request.
* Running Monarch OA Identification...
Normal: The system is not a monarch OA so skipping monarch OA
* Checking for System Management Homepage and other HP web agents...
Normal: The system is not a server, storage or desktop. Skipping the check
for System Management Homepage.
* Running HP Serviceguard Identification...
* Running SNMP System Type manager ...
Normal: The system does not support SNMP.
* Running SNMP subtypes identification...
* Resolving DNS names...
Normal: The fully qualified domain name was successfully resolved for the
* Checking if the Node is a Virtual Center...
Normal: Skipping MxVirtualCenter Identifier.
* Running Virtual Machine Management (VMM) Plug-in Identification...
* Building system relationships...
Minor: The Secure Shell key-based access authentication is not configured
on the system(s).
Minor: System Management Homepage (SMH) is not installed or is not
responding on the system(s).
* Running system Manage Communication diagnosis...
* System identification finished on system.



P.S. This thread has been moved from Management Software to ITRC HP Systems Insight Manager Forum. - Hp Forum Moderator

Occasional Visitor

Re: Trouble setting up HPSIM 7.4

It turns out that adding the domain to the global credentials seems to have solved this issue.

Trusted Contributor

Re: Trouble setting up HPSIM 7.4

The credentials used will depend on the protocol you wish to use for your Windows servers.  There is a section in the SIM user guide that explains all the OS requirements to get things discovered properly.


For Windows you have two options: SNMP and WBEM.  SNMP will require the Management Agents at minimum plus the SNMP service configured to allow the SIM server to communicate (community name, SIM server listed as authorized host, etc).  WBEM requires the HP WBEM Provider and agents at a mininum, then admin credentials (a special user, local admin, or a domain user with admin priveleges). 


I assume since adding admin creds got it working, you've got things set up using WBEM.


Honored Contributor

Re: Trouble setting up HPSIM 7.4

Just one addition, you don't exactly need an Admin account for WBEM. You can run a repair for the servers you want to use wbem for and have the option use a non Admin account for wbem. You only need an Admin account to set these but these credentials don't get stored so this could be your own account. Never use you own account for Discovery only for reparatie as the repair won't store and use your credentials.
Kind regards,