Servers - General

Hard disk detected for Linux installation but fail to boot

 
icamps
Occasional Collector

Hard disk detected for Linux installation but fail to boot

I have a SGI server (SGI C4002 Server, 2016) where I can install Linux but after that, it did not recognize the hard disk and cannot boot.

The hard disk is listed in the BIOS and it is found for installation from different tested Linux distros like DEBIAN, UBUNTU and OPENSUSE.

Any ideas are welcome.

Regards,

Camps

7 REPLIES 7
SanjeevGoyal
HPE Pro

Re: Hard disk detected for Linux installation but fail to boot

Hello,

 

Please shar the POST error messages for further investigation.

 


I am a HPE Employee

Accept or Kudo

icamps
Occasional Collector

Re: Hard disk detected for Linux installation but fail to boot

The error is just:
"No boot device found"
SanjeevGoyal
HPE Pro

Re: Hard disk detected for Linux installation but fail to boot

Hello,


I would suggest, you have to log a proper case with HPE, and share the appropriate logs for further analysis.


If you feel this was helpful please click the KUDOS! thumb below!   


Regards,


I am a HPE Employee

Accept or Kudo

icamps
Occasional Collector

Re: Hard disk detected for Linux installation but fail to boot

There is no log file.

The OS installation always run fine, withou any error or message.

After restarting to boot from server, the message appear about not detecting any booting partition. Just that.

 

A question: is there a BIOS update for that server?

No Kudos right now, sorry.

 

SanjeevGoyal
HPE Pro

Re: Hard disk detected for Linux installation but fail to boot

Hello,

I would suggest, you have to log a proper case with HPE, and share the appropriate logs for further analysis.

If you feel this was helpful please click the KUDOS! thumb below and accept the solution.
Regards,

 


I am a HPE Employee

Accept or Kudo

Clauden12
Occasional Visitor

Re: Hard disk detected for Linux installation but fail to boot

If the computer is dropped or jarred, the hard drive might have moved and disrupted the connection and that will cause the test to fail or prevent the test from starting.

 

 

icamps
Occasional Collector

Re: Hard disk detected for Linux installation but fail to boot

Hello @Clauden12 .

 

Nope, the computer did not drop or something.

Also, we tested with more than one hard disk. All the hard disk tested, bootted when put ini other computers.