Servers - General

Re: Microserver gen10 plus can't receive ipv6 router advertisement

 
jresins
Occasional Contributor

Microserver gen10 plus can't receive ipv6 router advertisement

hardware:  Microserver gen10 plus

OS: windows Server 2019 datacenter

network  adapter:  onboard intel i350

There is a router in my network periodically send ipv6 router advertisement.  All the other clients except the microserver gen10 plus can receive the ra packets and periodically update the client configurations.

I use wireshark to capture the packets of the microserver,  found it didn't receive any IPv6 router advertisements to ff02::1.   That's quite strange.   I searched the internet and found no solutions.

Can anybody help ? thanks .

7 REPLIES 7
TVVJ
HPE Pro

Re: Microserver gen10 plus can't receive ipv6 router advertisement

Hello,

It sounds like you may need to configure IPv6 address for the communication between the server and the router.

Regards,

 

I work for HPE
Views expressed herein are my personal opinion and are not the views of HPE

Accept or Kudo

jresins
Occasional Contributor

Re: Microserver gen10 plus can't receive ipv6 router advertisement

The ipv6 address is assigned by the DHCPv6 Server(stateful),  all the clients could get the ipv6 address.

I used wireshark to capture the packets of the nic, found the gen10 plus couldn't get the  Router Advertisement sent to   ff02::1 by the router.

The picture  below shows the difference of  capture result between gen 10  plus and PC in the same lan(same gateway, same netmask, no layer 2 isolation)  and the same time period.  The kali linux environment is gen10 plus which boot from USB live system, so just ignore the time difference displayed in wireshark(it was caused by the time zone configuration).

gen10 plus RA.png

Today, I captured the gen10 plus in windows again, found it could get the multicast router advertisement now. I don't know why? what I did these days were: enabled the hyper-V and vswitch function of the windows system, updated my openwrt router with some packages wich opkg update  and opkg upgrade.

gen 10 plus ra2.PNG

ksram
HPE Pro

Re: Microserver gen10 plus can't receive ipv6 router advertisement

Hi,

Good day!

Looks like updating the Packages has helped here to resolve the issue.

Could you please confirm if all working now as expected?

Thank you

RamKS


I work for HPE

Accept or Kudo

jresins
Occasional Contributor

Re: Microserver gen10 plus can't receive ipv6 router advertisement

Yes, it seems work as expected in windows 2019 now.  I'll make a test in kali linux later.

ksram
HPE Pro

Re: Microserver gen10 plus can't receive ipv6 router advertisement

Hi,

 

Thats sounds good.

 

May be if any issues in Linux, we can start a new thread for further discussions.

 

Thank you

RamKS


I work for HPE

Accept or Kudo

Vargav895
New Member

Re: Microserver gen10 plus can't receive ipv6 router advertisement

Thanks to this article I can learn more. Expand my knowledge and abilities. Actually the article is very real.

 

techin
Regular Advisor

Re: Microserver gen10 plus can't receive ipv6 router advertisement

@jresins ..Did your issue get resolved?