Servers - General

RESTful Interface Tool errors

 
SOLVED
Go to solution
mhaz
Occasional Visitor

RESTful Interface Tool errors

I'm trying to use the restful interface tool to automate some bios changes on a few of my ProLiant DL360's Gen9s and Gen10s

When i try to change any settings via the "set" command i get the below error..

"Location data is empty

Unable to locate registry model"

Has anyone seen this error before? I've checked my ilo firmware and reset it however this made no difference 

3 REPLIES 3
Tech_Aniket
HPE Pro

Re: RESTful Interface Tool errors

Hello Mhaz,

Thank you for posting your query.

Could you please advise for which setting/parameter(s) are you getting this error? Or is it seen for all settings?

You can also review the Restful Interface tool user guide - https://hewlettpackard.github.io/python-redfish-utility/#bootorder-command-examples

 

Thank you

 

I am an HPE Employee

Accept or Kudo

Srinath_Raju
HPE Pro

Re: RESTful Interface Tool errors

Hi Mhaz,

Please make sure that the system bios and Ilo are updated to the latest. Once this is done, change the format to english (United States) under Control Panel -> Region and Language on my client. If you live outside of the United States you may have a localized format setting based on your location.

Do not unzip the file. Just place the zip file in the same directory as the hprest executable


Regards

Sr

I am a HPE Employee

Accept or Kudo

mhaz
Occasional Visitor
Solution

Re: RESTful Interface Tool errors

Hi,

 

Thank you for your replys

I ended up reinstalling the restful interface tool on another server and it is now working fine. Perhaps my local installation was corrupt.

Regards,

Mhaz