StoreVirtual Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Remove Failed FOM from Management Group

SOLVED
Go to solution
dataper
Occasional Visitor

Remove Failed FOM from Management Group

WE lost the host server with the FOM on it.  We had not backed up the FOM (yah - I know).  I would like to create a new FOM but it will not let me remove the failed FOM or add the new FOM.  What's the trick?

3 REPLIES
Solution

Re: Remove Failed FOM from Management Group

What i do in my demo lab to resolve this was the following:

  1. deploy a new FOM  (using the installer), make sure you configure DHCP for eth0, and eth1.
  2. finish the installer and check if the FOM has booted up normally.
  3. shut the FOM down.
  4. Lookup the original FOM manager mac adress in CMC, close down CMC
  5. Change the Mac adress of the 1st ethernet adapter of the FOM VM to the mac adress from the previous step and save the FOM VM
  6. Bootup the FOM VM
  7. Logon via the FOM VM console to the FOM VM and change the IP adress, subnet and gateway for eth0 to the original FOM's Ipadress 
  8. reboot the FOM for good measure
  9. start CMC
  10. CMC will now see and talk to the FOM, but put it in an error state as the configuration is unknwon/wrong , but it will allow you to remove the FOM from the cluster
  11. re-add the new FOM if you still need a FOM
  12. done

 

AEB_Company
Occasional Collector

Re: Remove Failed FOM from Management Group

Thanks, it worked for us! We had the same problem about a week ago.

It's a bit tricky to change the MAC address of the new FOM. VMware reports that the MAC "is not an allowed static Ethernet address". We had to edit the .vmx file of the VM and add the following line:

ethernet0.checkMACAddress = "FALSE"

 

dataper
Occasional Visitor

Re: Remove Failed FOM from Management Group

Thanks!

That worked perfectly.