Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve Default routing

 
SOLVED
Go to solution
Occasional Advisor

Procurve Default routing

I am configuring default routing on 5406 switch.

Two routers are connected to the same VLAN on the switch. The IPs for VLAN and connecting router interfaces are with /23 mask. I have configured a default route and a static route.

ip route 0.0.0.0 0.0.0.0 10.21.21.250
ip route 10.21.22.0 255.255.254.0 10.21.21.254

Default route is working fine. The static route is not forwarding the packets to the interface 10.21.21.254. Is there anything else to be configured?

I am using the image K.14.34
13 REPLIES 13
Honored Contributor

Re: Procurve Default routing

Hi,

Have you checked that the route is actually in your routing tables?
"sh ip route"
Occasional Advisor

Re: Procurve Default routing

Hi Mohammed,

Below is the "sh ip route" output.


Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 10.21.21.250 7 static 1 1
10.21.20.0/23 Server & NW ... 7 connected 1 0
10.21.22.0/23 10.21.21.254 7 static 1 1
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0

Further I am able to ping the switch IP 10.21.23.254 from the switch 10.21.21.249. When I connect a laptop and ping the IP 10.21.23.254 I get a message "10.21.21.249 : destination net unreachable".
Honored Contributor

Re: Procurve Default routing

Can you post the up the running config for your switch?
Occasional Advisor

Re: Procurve Default routing

hostname "Router-1"
module 1 type J8702A
module 2 type J8702A
module 3 type J8706A
interface B1
name "Uplink to Internet Router"
exit
interface B23
name "Trunk Port to Access Switch"
exit
interface B24
name "Trunk Port to Access Switch"
exit
interface A1
name "Link to Router-2" "
exit
interface A2
name "Uplink to Voice Gateway"
exit
trunk B23-B24 Trk1 LACP
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged B19-B22,C1-C24
tagged Trk1
no untagged A1-A24,B1-B18
no ip address
exit
vlan 7
name "Server & NW VLAN"
untagged A1-A24,B1-B18
ip helper-address 10.19.135.220
ip helper-address 10.19.135.222
ip helper-address 10.23.45.5
ip helper-address 10.21.21.220
ip address 10.21.21.249 255.255.254.0
tagged Trk1
exit
ip route 0.0.0.0 0.0.0.0 10.21.21.250
ip route 10.21.22.0 255.255.254.0 10.21.21.254

management-vlan 7
no autorun
password manager
password operator
Honored Contributor

Re: Procurve Default routing

Ok, so I'm assuming that the laptop that you connected was on VLAN 1?
Occasional Advisor

Re: Procurve Default routing

I connected the laptop to vlan 7
Honored Contributor

Re: Procurve Default routing

Oh, ok, so what IP address does the laptop get?
What is the device 10.21.21.254 and what port is it connected to the 5406 on?
Occasional Advisor

Re: Procurve Default routing

Laptop IP 10.21.21.150/23
GW - 10.21.21.249
Connected to port B16
Honored Contributor

Re: Procurve Default routing

And which port is 10.21.21.254 connected to?