Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve routing issue

SOLVED
Go to solution
Alex JFX
Occasional Visitor

Procurve routing issue

Note: Since public ips are posted, the first few digits have been replaced with xx.xx

I have an HP Procurve 2650 layer3 switch and I am trying to subnet my C-class obtained from the provider and setup routing for it. The block is xx.xx.69.0/24, gateway xx.xx.69.1

I have 2 VLAN's:

DEFAULT_VLAN (Untagged ports: 1, 3-50)(Ip: xx.xx.69.62, Subnet Mask:255.255.255.0)
BIGVLAN (Untagged ports: 2)(Ip: xx.xx.69.65, Subnet Mask:255.255.255.192)

IP routing is enabled and i added a static route 0.0.0.0/0 xx.xx.69.1

Port 1 is connected to the internet. The switch is online and has full internet access. I can ping anything from the CLI interface.

Port 2 is connected to a PC. The PC's ip is xx.xx.69.66, subnet mask 255.255.255.192. The PC can only ping xx.xx.69.65 and xx.xx.69.62, but nothing outside of that.





Here's the output of "show ip" command:
===============================================
ProCurve Switch 2650# show ip

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64
Arp Age : 20

VLAN | IP Config IP Address Subnet Mask Proxy ARP
------------ + ---------- --------------- --------------- ---------
DEFAULT_VLAN | Manual xx.xx.69.62 255.255.255.0 No
BIGVLAN | Manual xx.xx.69.65 255.255.255.192 No
===============================================







Here's the output of the "ip route" command:
===============================================
ProCurve Switch 2650# show ip route

IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
0.0.0.0/0 xx.xx.69.1 1 static 1 1
xx.xx.69.0/24 DEFAULT_VLAN 1 connected 0 0
xx.xx.69.64/26 BIGVLAN 2 connected 0 0
127.0.0.0/8 reject static 0 250
127.0.0.1/32 lo0 connected 0 0
===============================================






Here's the output of "show config" command:
===============================================
ProCurve Switch 2650# show config

Startup configuration:

; J4899B Configuration Editor; Created on release #H.10.31

hostname "ProCurve Switch 2650"
snmp-server contact "Alex"
time timezone -5
ip default-gateway xx.xx.139.65
ip routing
snmp-server community "Server" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1,3-50
ip address xx.xx.69.62 255.255.255.0
no untagged 2
exit
vlan 2
name "BIGVLAN"
untagged 2
ip address xx.xx.69.65 255.255.255.192
exit
ip route 0.0.0.0 0.0.0.0 xx.xx.69.1
===============================================



How do i make other ips accessible to the PC?
2 REPLIES
Matt Hobbs
Honored Contributor
Solution

Re: Procurve routing issue

You've got an overlapping IP address scheme there which I wouldn't recommend. I'd first make VLAN1 255.255.255.192, e.g:

Network ID Range Broadcast
10.0.69.0 10.0.69.1 - 10.0.69.62 10.0.69.63
10.0.69.64 10.0.69.65 - 10.0.69.126 10.0.69.127
10.0.69.128 10.0.69.129 - 10.0.69.190 10.0.69.191
10.0.69.192 10.0.69.193 - 10.0.69.254 10.0.69.255

You should also change the clients on VLAN1 to use this subnet mask.

Second, you need to enable 'ip proxy-arp' - this will allow the router to answer ARP requests on behalf of other VLANs. In this case, this is required since your ISP simply thinks you have the larger /24 bit subnet - it will always ARP out to find your hosts. Since your hosts are going to be on different VLANs, usually they would not be able to hear those ARP requests. Proxy-arp will realise that it services those addresses, and will reply to your ISPs router with its mac-address instead.

You may be able to get away with just enabling proxy-arp for now, but I would make the subnet mask change as you might get other unexpected behaviour.
Alex JFX
Occasional Visitor

Re: Procurve routing issue

Thank you!
ip proxy-arp solved the problem