Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp through procurve 2524 not working

Thomas Liss
Occasional Visitor

dhcp through procurve 2524 not working

Hi there,

we have two 2524 switches linked together and all our servers and workstations connected there. All network traffic is fine besides DHCP. When setting up a DHCP Server (Windows 2003), it works fine for a short time and then stops responding, meaning clients get a timeout when trying to get an IP. I totally reinstalled one of the servers, made it a DHCP server and it was working correctly. After about 1 hour, I changed some options on DHCP, tried to renew my client ip - timeout. Some sniffing with ethereal revealed the Discover packets being broadcast and reaching the DHCP, but even though the stats on the DHCP server show that he offers, I don't see any offer packets on the network. Request & acknowledge never happen. I plugged my notebook in the port next to the one with the DHCP server, but nothing.
The switches are set up in a basic configuration with 1 VLAN each, containing all the ports, no spanning tree, all ports untagged. I also tried clearing the arp tables, but it had no effect.

I am out of ideas. Maybe anyone has a clue as to why all network traffic is working fine besides DHCP?

Thanks in advance,

Thomas Liss
2 REPLIES
Kell van Daal
Respected Contributor

Re: dhcp through procurve 2524 not working

Did you also sniff the port where the DHCP server is on?
In that case if you don't see any offers, than the server is probably not sending them.
To get an even better check of that, is to connect your notebook directly on the DHCP server with a crosscable and then run a sniffer.

If you see offers, than the switch has a problem. If you don't see offers, than the server has a problem.

Do you have multiple nic's in the server?
If so, check the binding, and disable unused nic's.
Also check the DHCP logfile (c:\windows\system\dhcp (default location)).
Thomas Liss
Occasional Visitor

Re: dhcp through procurve 2524 not working

Hi,

thanks for your reply. In the meantime, I fortunately figured out that the problem was not on the switch but on the DHCP Server. It lost its authorization in the Active Directory every hour or so. Reinstalling it on a different server fixed that.

Best,

Thomas