Switching and Routing
1754057 Members
2843 Online
108811 Solutions
New Discussion юеВ

Multicast issue

 
SOLVED
Go to solution
bigmaneric97
Occasional Advisor

Multicast issue

We have a team working on a product that is sending out commands via multicasr. We are trying to be able to send this informationso to all devices on certain vlans. of course the multicast works inside the same vlan but I can not seem to get it to work across different vlans. My first thought is there is not enough information being sent. there are 3 packet in under 0.3 seconds. Here is some of my config and other information

Config:

-------

ip routing
ip multicast-routing

----------------

vlan 708
name "VLAN708"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.8.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.18.255 2401
ip forward-protocol udp 172.17.18.255 2402
ip forward-protocol udp 172.17.8.255 2401
ip forward-protocol udp 172.17.8.255 2402
ip forward-protocol udp 172.17.8.255 2400
ip forward-protocol udp 172.17.12.255 2400
ip forward-protocol udp 172.17.18.255 2400
ip forward-protocol udp 172.17.12.255 2401
ip forward-protocol udp 172.17.12.255 2402
ip igmp
ip pim-sparse
ip-addr any
exit
ipv6 enable
ipv6 address fd87:73b9:6277:2c3::1/64
ipv6 helper-address unicast fd87:73b9:6277:64::4d
exit

vlan 712
name "VLAN712"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.12.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.18.255 2401
ip forward-protocol udp 172.17.18.255 2402
ip forward-protocol udp 172.17.8.255 2401
ip forward-protocol udp 172.17.8.255 2402
ip forward-protocol udp 172.17.12.255 2401
ip forward-protocol udp 172.17.12.255 2402
ip forward-protocol udp 172.17.8.255 2400
ip forward-protocol udp 172.17.12.255 2400
ip forward-protocol udp 172.17.18.255 2400
ip igmp
ip pim-sparse
ip-addr any
exit
ipv6 enable
ipv6 address fd87:73b9:6277:2c7::1/64
ipv6 helper-address unicast fd87:73b9:6277:64::4d
exit

 vlan 718
name "VLAN718"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.18.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.8.255 2401
ip forward-protocol udp 172.17.8.255 2402
ip forward-protocol udp 172.17.12.255 2401
ip forward-protocol udp 172.17.12.255 2402
ip forward-protocol udp 172.17.18.255 2401
ip forward-protocol udp 172.17.18.255 2402
ip forward-protocol udp 172.17.8.255 2400
ip forward-protocol udp 172.17.12.255 2400
ip forward-protocol udp 172.17.18.255 2400
ip igmp
ip pim-sparse
ip-addr any
exit
ipv6 enable
ipv6 address fd87:73b9:6277:2cd::1/64
ipv6 helper-address unicast fd87:73b9:6277:64::4d
exit

--------

HQ-SW-SR1# sh ip igmp vlan 708 config

IGMP Service VLAN Config

 

VLAN ID : 708
VLAN NAME : VLAN708
IGMP Enabled [No] : Yes
Querier Allowed [Yes] : Yes
IGMP Version [2] : 2
Strict Mode : No
Last Member Query Interval (Seconds) [1] : 1
Querier Interval [125] : 125
Query Max. Response Time (Seconds) [10] : 10
Robustness Count [2] : 2

Port Type | Port Mode Forced Fast Leave Fast Leave
------- ---------- + --------- ----------------- ----------
F5 1000T | Auto No Yes
F12 1000T | Auto No Yes
F17 1000T | Auto No Yes
F18 1000T | Auto No Yes
L13 1000T | Auto No Yes
Trk10 Trunk | Auto No Yes
Trk22 Trunk | Auto No Yes
Trk30 Trunk | Auto No Yes

---------------

VLAN ID : 708
VLAN Name : VLAN708
IGMP version : 2
Querier Address [this switch] : 172.17.8.1
Querier Port :
Querier UpTime : 6d 16h 34m 57s
Querier Expiration Time : 0h 0m 55s

Active Group Addresses Type        Expires          Ports        Reports    Queries
----------------------           ---------- --------------- ---------- -------          -------
239.255.255.250                Filter         0h 3m 30s    Trk10      17135           0

 

It just flashed in my mind that:

ip forward-protocol udp 172.17.8.255 2401

should be the vlan IP:

ip forward-protocol udp 172.17.8.1 2401

 

I can see the traffic for 239.255.255.250 in wire shark going from the device.

 

Thank you,

Eric Speake.

 

4 REPLIES 4
Emil_G
HPE Pro
Solution

Re: Multicast issue

Hello, 

If you want mutlicasts to be routed between VLANs you have to setup multicast routing. This switches support PIM sparse and dense mode. We can see that you have enabled pim sparse along with igmp on all the VLANs. PIM sparse mode requires also additional settings, especially RP (randezvous point) configuration. Please provide the commands in the "router pim" section of the config.

In which VLAN is located the source of the mutlicast? Is the source connected directly to this switch or to another mutlicast routing switch?

What is the IP address of mutlicast source?

Which device is configured resp elected to be the RP for this multicast group?

We can see IGMP information only for VLAN 708. You should check for the rest of the VLANs where mutlicast receives are located if IGMP has registered joins for this group. If there are no joins PIM will not route traffic to this VLANs.

Maybe you can also provide the output of the following commands

show ip pim

show ip pim pending

show ip mroute

show ip mroute <group-address> <source-address>

show ip pim neighbors

show ip pim rp-set

For more information on PIM you can check the Aruba mutlicast and routing guide

https://support.hpe.com/hpsc/doc/public/display?docId=a00091313en_us

 

I am an HPE employee

Accept or Kudo


bigmaneric97
Occasional Advisor

Re: Multicast issue

Thanks for the reply. I'll start with the commands at the bottom.

After doing :

router pim
enable
exit

 

HQ-SW-SR1# show ip pim

PIM Global Parameters

PIM Status : Enabled
State Refresh Interval (sec) : 60
Join/Prune Interval (sec) : 60
SPT Threshold : Enabled
Traps : none

HQ-SW-SR1# show ip pim pending

Join Pending

Group 232.44.44.233
(*,G) Pending
Incoming VLAN: 712

HQ-SW-SR1# show ip pim pending

Join Pending

Group 232.44.44.233
(*,G) Pending
Incoming VLAN: 712

HQ-SW-SR1# show ip mroute

IP Multicast Route Entries

Total number of entries : 14

Group Address Source Address Neighbor VLAN
--------------- --------------- --------------- ----
239.255.255.250 172.17.18.14 172.17.18.14 718
239.255.255.250 172.17.18.15 172.17.18.15 718
239.255.255.250 172.17.20.16 172.17.20.16 720
239.255.255.250 172.17.20.19 172.17.20.19 720
239.255.255.250 172.17.20.23 172.17.20.23 720

HQ-SW-SR1# show ip mroute

IP Multicast Route Entries

Total number of entries : 14

Group Address Source Address Neighbor VLAN
--------------- --------------- --------------- ----
239.255.255.250 172.17.18.14 172.17.18.14 718
239.255.255.250 172.17.18.15 172.17.18.15 718
239.255.255.250 172.17.20.16 172.17.20.16 720
239.255.255.250 172.17.20.19 172.17.20.19 720
239.255.255.250 172.17.20.23 172.17.20.23 720


HQ-SW-SR1# show ip mroute 239.255.255.250 172.17.8.254

IP Multicast Route Entry

Group Address : 239.255.255.250
Source Address : 172.17.8.254
Neighbor : 172.17.8.254
VLAN : 708
Up Time (sec) : 340
Expire Time (sec) : 269

Multicast Routing Protocol : PIM-SM
Unicast Routing Protocol : connected

Metric : 1
Metric Pref : 0
Assert Timer : 0
RP tree : No

Downstream Interfaces

VLAN State Up Time (sec) Expire Time (sec)
---- ---------- ------------------ ------------------
708 forwarding 340 213
712 forwarding 340 212
718 forwarding 340 211

HQ-SW-SR1# show ip pim neighbors
Invalid input: neighbors

HQ-SW-SR1# show ip pim rp-set

Status and Counters - PIM-SM Static RP-Set Information

Group Address Group Mask RP Address Override
--------------- --------------- --------------- --------


Status and Counters - PIM-SM Learned RP-Set Information

Group Address Group Mask RP Address Hold Time Expire Time
--------------- --------------- --------------- --------- ---------------

The other VLANS:

 

HQ-SW-SR1# sh ip igmp vlan 712 config

IGMP Service VLAN Config

 

VLAN ID : 712
VLAN NAME : VLAN712
IGMP Enabled [No] : Yes
Querier Allowed [Yes] : Yes
IGMP Version [2] : 2
Strict Mode : No
Last Member Query Interval (Seconds) [1] : 1
Querier Interval [125] : 125
Query Max. Response Time (Seconds) [10] : 10
Robustness Count [2] : 2

Port Type | Port Mode Forced Fast Leave Fast Leave
------- ---------- + --------- ----------------- ----------
F5 1000T | Auto No Yes
F12 1000T | Auto No Yes
F17 1000T | Auto No Yes
F18 1000T | Auto No Yes
L13 1000T | Auto No Yes
Trk10 Trunk | Auto No Yes
Trk22 Trunk | Auto No Yes
Trk30 Trunk | Auto No Yes

 

HQ-SW-SR1# sh ip igmp vlan 718 config

IGMP Service VLAN Config

 

VLAN ID : 718
VLAN NAME : VLAN718
IGMP Enabled [No] : Yes
Querier Allowed [Yes] : Yes
IGMP Version [2] : 2
Strict Mode : No
Last Member Query Interval (Seconds) [1] : 1
Querier Interval [125] : 125
Query Max. Response Time (Seconds) [10] : 10
Robustness Count [2] : 2

Port Type | Port Mode Forced Fast Leave Fast Leave
------- ---------- + --------- ----------------- ----------
F5 1000T | Auto No Yes
F12 1000T | Auto No Yes
F17 1000T | Auto No Yes
F18 1000T | Auto No Yes
L13 1000T | Auto No Yes
Trk10 Trunk | Auto No Yes
Trk22 Trunk | Auto No Yes
Trk30 Trunk | Auto No Yes

 

vlan 708
name "VLAN708"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.8.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.8.1 2401
ip forward-protocol udp 172.17.8.1 2402
ip forward-protocol udp 172.17.12.1 2401
ip forward-protocol udp 172.17.12.1 2402
ip forward-protocol udp 172.17.18.1 2401
ip forward-protocol udp 172.17.18.1 2402
ip forward-protocol udp 172.17.8.1 2400
ip forward-protocol udp 172.17.12.1 2400
ip forward-protocol udp 172.17.18.1 2400
ip igmp
ip pim-sparse
ip-addr any
exit

vlan 712
name "VLAN712"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.12.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.8.1 2401
ip forward-protocol udp 172.17.8.1 2402
ip forward-protocol udp 172.17.12.1 2401
ip forward-protocol udp 172.17.12.1 2402
ip forward-protocol udp 172.17.18.1 2401
ip forward-protocol udp 172.17.18.1 2402
ip forward-protocol udp 172.17.8.1 2400
ip forward-protocol udp 172.17.12.1 2400
ip forward-protocol udp 172.17.18.1 2400
ip igmp
ip pim-sparse
ip-addr any
exit

vlan 718
name "VLAN718"
tagged F5,F12,F17-F18,L13,Trk10,Trk22,Trk30
ip address 172.17.18.1 255.255.255.0
ip helper-address 192.168.0.77
ip forward-protocol udp 172.17.8.255 2401
ip forward-protocol udp 172.17.8.255 2402
ip forward-protocol udp 172.17.12.255 2401
ip forward-protocol udp 172.17.12.255 2402
ip forward-protocol udp 172.17.18.255 2401
ip forward-protocol udp 172.17.18.255 2402
ip forward-protocol udp 172.17.8.255 2400
ip forward-protocol udp 172.17.12.255 2400
ip forward-protocol udp 172.17.18.255 2400
ip igmp
ip pim-sparse
ip-addr any
exit

 I also added router rip to the configuration

 

Emil_G
HPE Pro

Re: Multicast issue

Hello @bigmaneric97 

Do I see it correctly that pim was not enabled globally by now?

The outout of this command should be actually showing that the mutlicast stream is forwarded in VLANs 712 and 718. 708 is the VLAN of the source.

HQ-SW-SR1# show ip mroute 239.255.255.250 172.17.8.254

Downstream Interfaces

VLAN State Up Time (sec) Expire Time (sec)
---- ---------- ------------------ ------------------
708 forwarding 340 213
712 forwarding 340 212
718 forwarding 340 211

Did you check if the clients in this VLAN are receiving the mutlicast now?

I am an HPE employee

Accept or Kudo


bigmaneric97
Occasional Advisor

Re: Multicast issue

Do I see it correctly that pim was not enabled globally by now? That is correct.

 

They are testing this now. Looking at a packet capture we can see the traffic the engineers are expecting to see. We just need to make sure they are working in SQA.

 

Thanks for the help. I will let you know soon if this is working.

 

Eric