cancel
Showing results for 
Search instead for 
Did you mean: 

Console doesnt work

SOLVED
Go to solution
rustam_2
Super Advisor

Console doesnt work

I've wanted to install DB Oracle today. I made Display environment
$ DISPLAY=IP:0.0: export=DISPLAY
then wanted to run installer file.
when i came back to MP(Ctrl+B) for signing to console, i got strange thing.
mp->co gives me this sign >, not $ or #
doesnt take any commands. What's wrong?
27 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: Console doesnt work

">" is probably the shell's "secondary prompt".

It means there was an un-closed parenthesis or quote on a previous command line. The shell is prompting for you to write the rest of the command. When a command line with the correct closing element (closing parenthesis or the correct type of a quote) is entered, the shell will attempt to execute everything from the original command to the command line with the closing element as one long command line.

If you've tried to enter any commands to the > prompt, the resulting multi-line command would probably be a mess. Type the interrupt character to restore the shell to the normal mode (Control-C if your session used the HP-UX default .profile). It throws away the accumulated multi-line command without trying to execute it.


When you disconnect from a MP, the system does not automatically log you out: you can even write a part of a command line on the console, press Ctrl-B, disconnect from MP, move to another PC, re-connect to the MP, use the CO command, write the rest of the command line and press Enter... and the command is executed just as if it was typed all at once.

This is intentional: it allows the sysadmin to start up long-running jobs (e.g. installing a new Quality Pack to an old, slow system) on the MP console. If the sysadmin's connection to MP fails, it does not cause the job to abort.

When reconnecting to a session that has a full-screen TUI running (e.g. swinstall in interactive mode), the display may be garbled. In that case, it is useful to know how to make the application refresh the terminal screen completely. The necessary keystroke is application-specific, but it is often either Control-L (the "form feed" character for printers) or Control-R (for "refresh").

MK
MK
rustam_2
Super Advisor

Re: Console doesnt work

Matti Kurkela
Thanks, when i did Ctrl+C, i got # for type commands. i could switch via su - otheruser, when i type su - root got crazy strings. i made screen in attach file.

Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

Hi,

the output you got from "Console" or your ssh/telnet session ?

you press enter->enter

if its console

export TERM=hp

HTH,

Johnson
Problems are common to all, but attitude makes the difference
Matti_Kurkela
Honored Contributor

Re: Console doesnt work

It says "Value of TERM has been set to 'vt100'"
Is your terminal/emulator using a vt100-compatible emulation? If the TERM variable setting does not match what your terminal/emulator actually uses, you'll get garbage on your screen.

Refreshing the display does not work in the command prompt: only full-screen TUIs do that.

It looks like the automatic terminal size detection may have failed. Just ignore the mess, press Enter once to make sure you have an empty command line, then type "clear" to clear the display, or "reset" to send a code to the terminal/emulator that resets all terminal display attributes to defaults.
The system registers only what you type, even if there is extra garbage on the screen.

You can use this command to force the re-detection of terminal size:

eval $(resize)

Sometimes even a simple "resize" command works, but when it is encapsulated by the eval statement, it also causes the COLUMNS and LINES environment variables to be set correctly. (Some shells do that automatically, but not all of them.)

MK
MK
rustam_2
Super Advisor

Re: Console doesnt work

Thanks Johnson and Matti.
I use putty and connect ssh. Maybe i have to change terminal keyboard options? The parameter Function Key and Keypad is chosen - Esc(n~, maybe should be VT100+ ?

i see, there is a mail, where a lot information (from 20 may 2009). Could be this mail due of this error?
Bill Hassell
Honored Contributor

Re: Console doesnt work

Do you have TERM=something in your login profiles? HP-UX accommodates dozens of different terminal emulators but since yoiu don't know what any particular use might be using, you need to fix the default HP profiles to eliminate the hardcoded TERM= with the automatic identifier program: ttytype. To see how it works, type this command:

ttytype -s

This program will send terminal identifier strings and looks for the type of terminal (emulator) you are using. In a standard HP /etc/profile, replace all this code:

# set term if it's not set

if [ "$TERM" = "" -o "$TERM" = "unknown" -o "$TERM" = "dialup" \
-o "$TERM" = "network" ]
then
eval `ttytype -s -a`
fi

export TERM

# set erase to ^H, if ERASE is not set
if [ "$ERASE" = "" ]
then
ERASE="^H"
export ERASE
fi
stty erase $ERASE

with this:

eval $(ttytype -s)
eval $(resize)

The (archaic) HP default assumes that your incoming terminal emulator has preset the terminal type using telnet subcodes -- never a good idea. Always detect the terminal automatically to avoid problems. Be sure to fix /etc/profile (for sane shells like ksh, POSIX or bash) and per-user profiles such as .profile.

Note that if you are setting DISPLAY=:0.0 then you are running a very different environment (Xwindows) which has no terminal emulation. Instead, you 'borrow' an emulator from the remote system such as xterm, dtterm or hpterm. The CTRL-B sequence is only meaningful for the real console, not standard network sessions such as ssh or telnet.


Bill Hassell, sysadmin
rustam_2
Super Advisor

Re: Console doesnt work

Thanks Bill Hassell
by the way, i changed .profile file. I add there this parameter umask 022, i add coz read about it here http://download.oracle.com/docs/cd/B19306_01/install.102/b25293/pre_install.htm section 2.14. To other words, i want to make user's environment in HP-UX.I've done these today:
1. add that parameter in ./profile
2. $DISPLAY=my_pc's_ip_address:0.0; export DISPLAY (not server's ip_address, where i'm gonna install Oracle)
but still says that my DISPLAY Environments doest set...
did i wrong?
Bill Hassell
Honored Contributor

Re: Console doesnt work

> 1. add that parameter in ./profile

umask 022 is always recommended for .profile

> 2. $DISPLAY=my_pc's_ip_address:0.0; export DISPLAY (not server's ip_address, where i'm gonna install Oracle) but still says that my DISPLAY Environments doest set...did i wrong?

This is referring to Xwindows, a special environment needed to (unfortunately) install Oracle these days (based on their docs). SO before you start, you must have an Xwindow emulator running on your PC. Without Xwindow support on your PC, the DISPLAY value is meaningless.

If you are running an Xwindow emulator, then be sure you follow the recommendations in the Oracle note. After setting the DISPLAY value to your PC's IP address, run the xhost command to allow the HP-UX system to connect to your Xwindow program. If that succeeds, then run a copy of xclock to see if a clock shows up on your PC screen. Finally, run a copy of xterm so you can get to a shell prompt in the Xwindow environment.


Bill Hassell, sysadmin
rustam_2
Super Advisor

Re: Console doesnt work

Thanks Bill.
> umask 022 is always recommended for .profile

Maybe i typed worng string? i brought my .profile's information in attach file.

>SO before you start, you must have an Xwindow emulator running on your PC.

I downloaded X Windows Emulator - Cygwin/X. Installed, after that would start as gives in official docs http://x.cygwin.com/docs/ug/using.html#using-starting
There are no startx.sh or bat files. Have u ever used this soft, or could u recommend me other X Windows Soft?

Regards,
Rustam

Re: Console doesnt work

Rustam,
You can try with xmanger, this will work well for you. You can download it from either of the below address:
http://www.netsarang.com/download/main.html

or

http://www.brothersoft.com/xmanager-download-72755.html

or

http://download.cnet.com/Xmanager/3000-7240_4-10038129.html
Thanks,
Regards,
ERIC.
rustam_2
Super Advisor

Re: Console doesnt work

Thanks, Duncan Eric Ogonji.
I installed X Manager 3.Configured X Start (typed host_ip,OS login and password, execution command:/usr/bin/X11/xterm -ls -display $DISPLAY).
Then Double Cliked to that icon-small windows-preparing to execute command and SSH User Authentication windows which requests password, i typed. But gives error message Xrcmd: "The X11 forwarding request was rejected.To solve the problem,turn on the X11 forwarding feature of the remote SSH server". Should i configure on HP-UX server some options or all config have to be on my PC?
Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

Should On the Server

http://tazman.princeton.edu/pipermail/osx/2005/000022.html

http://www.akadia.com/services/ssh_tips_and_tricks.html
Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

Thanks, Johnson Punniyalingam
I checked via root file 'vi sshd_config', but this file is new and empty? Is it ok with my server or something wrong?

Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

>>Is it ok with my server or something wrong?<<

if the file doesn't exist on the Server "Above error your post its not relevant " Can you check on PC settings ?

Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

Um... i entered to X manager Browser. Couldnt use XShell and Xftp, they are not work, when i clicked they are silence. Then i configured Xstart. Configuration of Xstart in Browser i made in attached file.
Maybe i have to change Security configuration somewhere...
Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

I 'was lost by seeing your attachment

My doubts

1. Protocol = SHH -> as per above "heard from you d'not have ssh_d_config file ?

Can we change telnet ?

2. Are you allowed to connect to server ? Security check ? any ip filter

check /var/adm/inetd.sec
Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

Thanks, Johnson Punniyalingam and all members.
Finallyyyyyy, i've done. I just changed to telnet, then rolled up in tray. I run runIntaller on HP-UX server, now i see GUI on my PC :)
P.S. By the way, i thought Xmanager is free, but now i c, i have evaluation period, 30 days :(
Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

>>P.S. By the way, i thought Xmanager is free, but now i c, i have evaluation period, 30 days :(<<

Are you referring to "X manager" under you PC ?

Better buy the "Licensed X manager" SW
Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

>> Are you referring to "X manager" under you PC ?
Sorry, i dont get it. Do u mean do i use on on pc or ...

License, i have to talk with my boss. Thanks for advice.
Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

use on on pc
Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

How? do i use only on pc, not Linux OS on Servers?
Johnson Punniyalingam
Honored Contributor

Re: Console doesnt work

>>P.S. By the way, i thought Xmanager is free, but now i c, i have evaluation period, 30 days :(<<

were did you see above message - if its on your pc ? for X manager that its refering to X manager software which you running the PC
so can purchase lincensed based Xmanager
Problems are common to all, but attitude makes the difference
rustam_2
Super Advisor

Re: Console doesnt work

Thanks, Johnson Punniyalingam.
I got.
rustam_2
Super Advisor

Re: Console doesnt work

I have similar problem like this today. I was importing dump file to my database and then got error. I found out the problem. But now i can't finish this process and run imp my dump file again. I attached screen, so how can i close the imp session? I couldn't find useful command for this situation here http://docs.hp.com/en/J2743-90003/ch05s05.html

Regards,
Rustam