HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Showing results for 
Search instead for 
Did you mean: 

DRD clone fails

Tom Ward_1
Honored Contributor

DRD clone fails

DRD clone fails

Latest release of DRD
# DRD B.1131.A.3.8.454 Dynamic Root Disk

OS disks
main disk10
mirror disk15

DRD disks
main disk11
mirror disk16

drd clone -v -t /dev/disk/disk11 -x verbosity=4 -x overwrite=true -x mirror_disk=/dev/disk/disk16

ERROR: Selection of the target disk fails.
- Selecting the target disk fails.
- Validation of the disk "/dev/disk/disk11" fails with the following error(s):
- The disk ";/dev/disk/disk11"; is in use on the system.
* Selecting Target Disk failed with 1 error.

Tried pvcreate on /dev/rdisk/disk11, but still fails.
strings /etc/lvmtab shows disk11 part of drd00
Tom Ward_1
Honored Contributor

Re: DRD clone fails

/dev/drd00 was active in LVM.
deactivate /dev/drd00 and vgexport it.

Then drd clone worked.
Tom Ward_1
Honored Contributor

Re: DRD clone fails

Clean up LVM.
Steven E. Protter
Exalted Contributor

Re: DRD clone fails


DRD requires the target disk not in use.

Its pretty common for systems to be mirrored.

Prior to drd clone we break the mirror.

drd does not do that for you, as the process is different for LVM versus vxvm

Steven E Protter
Owner of ISN Corporation
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com