cancel
Showing results for 
Search instead for 
Did you mean: 

Kernel Upgrade

Kernel Upgrade

Hi,

I am upgrading by Linux As 4 from 2.6.9-42.0.8.ELsmp to 2.6.9-42.0.10.ELsmp

but while installing the kernel module using RPM i get a error.

No module qla2xxx_conf found for kernel 2.6.9-42.0.10.EL.

If i restart my Server the SAN Disk dosent gets detected please help on this issue
In Love with Life
2 REPLIES
Matti_Kurkela
Honored Contributor

Re: Kernel Upgrade

There are at least two different versions of the qla2xxx driver: one (the basic version) is included with the RHEL 4 kernels, another (a version with built-in multipath functionality) is available separately from QLogic and HP.

Looks like you've used the separately-packaged version.

You should install the kernel*-devel package that matches your new kernel version. Then you must recompile the driver so that it matches your new kernel (basically the same thing you did when originally installing the driver package). See the installation instructions of the driver.

This does not overwrite the driver for your old kernel: each kernel version has a separate module directory under /lib/modules.

MK
MK
skt_skt
Honored Contributor

Re: Kernel Upgrade

you may do a copy some thing similar

â ¢ Copy the old /lib/modules/2.4.21-47.ELsmp/kernel/drivers/scsi/lpfcdd.o to the corresponding new kernel location(/lib/modules/2.4.21-53.ELsmp/kernel/drivers/scsi/lpfcdd.o)