cancel
Showing results for 
Search instead for 
Did you mean: 

Kernel errors for CDROM

Sudeesh
Respected Contributor

Kernel errors for CDROM

Hi Freinds,

I am getting the following error on couple of Linux boxes for cdrom. Any got any clue why it is happening?

ide-cd: cmd 0x3 timed out
hda: irq timeout: status=0xd0 { Busy }
ide: failed opcode was: unknown
hda: ATAPI reset complete

Running kernel is 2.6.18-128.1.6.el5


Thanks

Sudeesh
The most predictable thing in life is its unpredictability
4 REPLIES
Ragu_3
Trusted Contributor

Re: Kernel errors for CDROM

Please post some relevant detail w.r.t your system via lspci. Looks as if the relevant atapi cdrom driver is to be put in, there is just not enough info in your post.
Debian GNU/Linux for the Enterprise! Ask HP ...
chenfangqing
Occasional Visitor

Re: Kernel errors for CDROM

Hi Sudeesh,
Did you got the reason and solution?

I have same errors in my servers, and some system even will crash after about one month later(can't login by telnet/ssh/ftp from remote but ping).

The kernel is:Linux 2.6.18-8.el5xen.
lspci and dmesg log is attached.
rave_ace
Occasional Visitor

Re: Kernel errors for CDROM

Hi Guys,

Same error messages with 2 of our servers!

OS: Red Hat Enterprise Linux Server release 5.5 (Tikanga)

Kernel: 2.6.18-194.el5

Driver seems working fine, we put a disc into it and were able to read files from disc. But system generates these error messages.

Anyone knows the reason why?
Chhaya_Z
Valued Contributor

Re: Kernel errors for CDROM

Hi,

Please refer the below Redhat KB article for information on CD-ROM IRQ timeout error messages " kernel: hda: irq timeout: status=0xd0"

https://access.redhat.com/kb/docs/DOC-35652

Environment
â ¢Red Hat Enterprise Linux 4
â ¢Red Hat Enterprise Linux 5 versions before 5.4
â ¢HP DL380,DL580 and similar
â ¢CD-ROM model:TEAC DV-W28ECW, TEAC DV-28E-V, and similar

The workaround/solution was to increase timeout value to 10ms. Refer the below references.

If cannot update the kernel, you can disable the CDROM to avoid these messages. Edit the file /boot/grub/grub.conf, add the kernel parameter ide=nodma in the kernel line. Then reboot the system.

References:

â ¢Bugzilla RHEL4 : https://bugzilla.redhat.com/show_bug.cgi?id=456078

â ¢Bugzilla RHEL5: https://bugzilla.redhat.com/show_bug.cgi?id=464039
â ¢RHEL4 Errata: http://rhn.redhat.com/errata/RHSA-2009-1024.html
â ¢RHEL5 Errata: http://rhn.redhat.com/errata/RHSA-2009-1243.html

I hope this helps.
Regards,
Chhaya

I am an HP employee.
Was this post useful? - You may click the KUDOS! star to say thank you.