System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Need source for the HPE Intel IGB drivers v 5.3.5.3?

SOLVED
Go to solution
bytK7
Occasional Collector

Need source for the HPE Intel IGB drivers v 5.3.5.3?

I've been working for some time to get a couple of 361T dual NIC cards running on some DL20 Gen9 servers running Debian 7 with the Jessie backports kernel 3.16. The inlcuded IGB driver in that build is the Intel 5.0.5 driver, but that was failing to load the cards with a "probe failed" message and a -5 return code.

Looking at the HP download website for this card, I see that binary "HPE Intel igb Drivers" version 5.3.5.3 are available for RHEL and SUSE, but that the source provided is version 4.0.17, which is vastly too old for this hardware. I tried compiling and installing the 5.3.5.4 driver from the Intel-provided source, but is is still failing to load the cards (same error). It seems that the PCI addressing scheme or something is different between what the Intel driver expects and what HP has done with these cards (I tracked the failing line of code to be an ioremap call in the igb_probe function of the driver).

HP must have some specific tweaks to the IGB driver to accommodate their hardware. As a result, I believe I need to get the source code for the 5.3.5.3 version of the HP driver (I have the 1.10.8 firmware version installed on the cards), so I can compile it for our specific Debian kernel. However, I cannot find that available (the Intel IGB driver is GPL licensed, so HP should be providing the source of any binary releases), and the official HP support channel has been less than helpful so far.

Does anyone have any ideas as to where I cna find this source? Or, perhaps I'm totally off track and my question should instead be does anyo0ne have any other ideas what is wrong and how to get this to work? I'm honestly at the point of bailing on HP to get something that'll work with in-tree drivers...

6 REPLIES
Jimmy Vance
HPE Pro
Solution

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

Even though there are HPE drivers, the inbox drivers normally work fine. I checked with my counterpart who does the Ubuntu certifications.  12.04, 14.04 and 16.04 work just fine with the inbox driver. I mentioned you had Debian 7 with Jessie backports and he also said that should work without issue.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
GregDavis
Occasional Advisor

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

The Intel drivers you are using (both the one in Debian and the one you downloaded) are correct for this device.  If the system is still under warranty, you could file a support ticket on it to determine whether there is a problem with the device itself or the PCI riser.

 

bytK7
Occasional Collector

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

It's interesting to hear that this supposedly should work. I thought it might be bad hardware as you suggest, except I have the same problem on two different boxes with two different cards, I've tried both slots in the PCI risers, AND on top of all that, the cards work without issue in the Intelligent Provisioning utility.

bytK7
Occasional Collector

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

Thanks for the replies.

I'm still pulling my hair out with this one, but I think I can safely conclude it is not the driver that's the problem, but seemingly a kernel bug. I found that booting into the older Wheezy stable kernel (3.2) is fine with these cards, but the 3.16 from Jessie is not. Even booting the live CD into Jessie proper does not work with the cards.

I did find a 332T lying around, and that seems to work without issue at the moment. Might just ditch the Intel-based cards so I can get this up and running.

GregDavis
Occasional Advisor

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

Sorry you're losing hair over this, but I'm glad to learn you have identified the more likely source of the problem.  Please let us know when you get it figured out.  You are not likely to be the only one experiencing the issue.

bytK7
Occasional Collector

Re: Need source for the HPE Intel IGB drivers v 5.3.5.3?

Yeah, I certainly can't imagine I'd be the first with this problem.

Unfortunately, I probably won't be the last either. I found a 332T Broadcom-based card in one of our older spare servers and popped that in for a go. No problems at all. So it looks like for the sake of time we won't be solving this one, at least not right now. While we'd like to use the I350-based NICs, the 332T will work well enough.

Now I only wish I'd thought of trying the 332T a week ago....