System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Out of inodes on GFS file System

 
SOLVED
Go to solution
MikeL_4
Super Advisor

Out of inodes on GFS file System

We are running Red Hat 5.5, and our file systems are using GFS...

We have a file system that has run out of inodes... How can this be increased for a GFS file system ??

# gfs_tool df /home/smonitor
/home/smonitor:
SB lock proto = "lock_dlm"
SB lock table = "APSMON:gfs08"
SB ondisk format = 1309
SB multihost format = 1401
Block size = 4096
Journals = 3
Resource Groups = 60
Mounted lock proto = "lock_dlm"
Mounted lock table = "APSMON:gfs08"
Mounted host data = "jid=2:id=393219:first=0"
Journal number = 2
Lock module flags = 0
Local flocks = FALSE
Local caching = FALSE
Oopses OK = FALSE

Type Total Blocks Used Blocks Free Blocks use%
------------------------------------------------------------------------
inodes 2580593 2580593 0 100%
metadata 1165229 113033 1052196 10%
data 87714 86975 739 99%
#
4 REPLIES
MikeL_4
Super Advisor

Re: Out of inodes on GFS file System

Looking further, all of our gfs file systems show this 100% on inodes, so I don't think that is an issue....

The df command shows inodes are ok...
# df -i /home/smonitor
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/mapper/apsmonVG-lvol8
3633489 2582857 1050632 72% /home/smonitor
#

The df on the file system shows 73% full, but the gfs_tool shows 99%.... Not sure what to believe any more trying to figure this out..

# df -h /home/smonitor
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/apsmonVG-lvol8
15G 11G 4.1G 73% /home/smonitor
#
Zinky
Honored Contributor

Re: Out of inodes on GFS file System

WHat option did you use to create your GFS2 filesystem? If you planned on using it for zillions for files -- you should have chosen mail storage or something...
Hakuna Matata

Favourite Toy:
AMD Athlon II X6 1090T 6-core, 16GB RAM, 12TB ZFS RAIDZ-2 Storage. Linux Centos 5.6 running KVM Hypervisor. Virtual Machines: Ubuntu, Mint, Solaris 10, Windows 7 Professional, Windows XP Pro, Windows Server 2008R2, DOS 6.22, OpenFiler
Chhaya_Z
Valued Contributor
Solution

Re: Out of inodes on GFS file System

Hi Mike,

The below Redhat article has explanation about why gfs becomes slow when filesystem is close to 100%. The gfs tool output actually gives the number of resource groups.

https://access.redhat.com/kb/docs/DOC-6479

https://access.redhat.com/kb/docs/DOC-6466 ==> this article has information on why there is mismatch between df & du outputs.
Regards,
Chhaya

I am an HP employee.
Was this post useful? - You may click the KUDOS! star to say thank you.
MikeL_4
Super Advisor

Re: Out of inodes on GFS file System

Found the solution in using command:

gfs_tool reclaim