Showing results for 
Search instead for 
Did you mean: 

Problem booting up

Go to solution
Regular Advisor

Problem booting up

Dear all,

Here is a good one.
Today I had to add some space to the volume ( /app ) on a production server which is in a cluster with another one. To be safe, I decided to do this first on a test server ( did I mantian this was the first time I am doing this? ).
Production server is running HP-UX 11.11 and test server is an older N-class with HP-UX 10.0
To acomplish this, I ran this commands:

fuser -cu /app ( i killed 4 running processes )
umount /app
lvdisplay /dev/vg00/lvol8
lvextend -L 1024 /dev/vg00/lvol8 /dev/dsk/c2t0d0 /dev/dsk/c1t0d0
extendfs -F vxfs /dev/vg00/lvol8
mount -a

To my supprise, evrything worked just fine. I did the same thing on my production server. No problem.
However, after I rebooted the test server, I can not get it to start again.
I am getting error "Legacy PA HEX Chasis Code".
I did not reboot the production server so that one is ok. My question is, what have I done wrong? Am I going to have the same problem with production server after the reboot?
One thing that I am not sure about, is that I know disks were mirrored and I did not brake the mirror before extending the volume. Could this be a problem?
Any suggestion is wellcome.
Mridul Shrivastava
Honored Contributor

Re: Problem booting up

The error on the N-class after reboot is not related with the volume extend. Moreover if the volume is mirrored then breaking mirror is not required for extending the volume however it will get extended on both the disks if we are not adding new disk.

Since the mirroring is done on logical volume level so once the LV is mirrored and then if you extend it , that will get exteded across mirrors provided there is enough space.
Time has a wonderful way of weeding out the trivial
Vijay Dsouza
Frequent Advisor

Re: Problem booting up

Hi mvr,

As said the error during boot is surely not related to the activity of adding space to the lvol.its related to something else
Try the following
1.Shutdown the test box and disconnect any sotrage connected to it.
2. Boot up the test server without any io connections externally.
3.If the system boots fine then insert the external cables one by one and repeat the shutdown and powerup procedure.

4. Any issues Check for the lastest HPMC /var/tombstones/ts99 timestamp. Check the syslog and eventlog for errors and the root cause can be traced.


Regular Advisor

Re: Problem booting up

Thank you for responed. I am glad this is not related to adding the space.
I will try suggested solution and will let you know how it goes.
Regular Advisor

Re: Problem booting up

I am getting stuck at the
"aloc_pdc_pages: Reloacting PDC from 0xffff800000 to 0x5faab000"
Does this means anything to you?
Ian P Smith

Re: Problem booting up

It doesn't sound related to your volume extend. Where are your boot disks? Are they internal or fibre attached?
Honored Contributor

Re: Problem booting up

"Legacy PA HEX Chassis code" is not necessarily an error: a three-column display of chassis codes is a normal output when the system is running a self-test.

A message like
alloc_pdc_pages: Relocating PDC from 0xffff800000 to 0x5faab000

is also a normal part of HP-UX boot.
Some server models will output this message and then spend a *lot* of time with no visible output. This is normal, although it can be hard on the nerves of a new sysadmin.

A full reboot of a rp5450 (also known as L2000) can take about 10 minutes when the system has a lot of memory installed. As the N-class of servers uses the same generation of technology as the L-class but has double the amount of CPUs and memory, I'd expect it to take even longer to boot.

The full list of chassis codes for L and N class servers seems to be HP internal information, but website has a list of K class server chassis codes. The chassis codes of newer servers seem to use a similar structure in their chassis codes, so you can look at the first one or two digits of each code and find out the general meaning of the codes using the K class code listing.

Unfortunately the site seems to be *very* slow at the moment, so I cannot provide an exact link for you.

Anyway, many of the chassis codes just document how far the selftest or boot has progressed. When HP-UX has started up, codes of the form FxxF actually indicate the number of active CPUs and the current load level of the machine.

Regular Advisor

Re: Problem booting up

Thank you for the suggestions.
I have waited but, server is keep rebooting.
There is a one error, "major change in the system state" which is keep coming up.
Regular Advisor

Re: Problem booting up

I booted a server in a single user mode and remount all the volumes. After that server came up with no problem ..... strange, but it works.