System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Restoration of Data backup fails........

bijoy k
Advisor

Restoration of Data backup fails........

Hi Gurus ,

Case I

we are taking the backup through fbackup util , scheduled through cron .Some times back , we have tried to restore the directory from the tape to a different directory in the Server ( different file system ) , But that operation fails with the below mentioned error.

# frecover -x -X -v -i /opt/datapath -f /dev/rmt/1mn
frecover(2114): read error from input device (I/O error)
frecover(2114): read error from input device (Permission denied)
frecover(2113): unable to resync backup media
frecover(4301): /opt/datapath not recovered from backup media
#

Case II

I have performed a manual backup of the same data /opt/datapath on another tape and tried to restore the files to another directory in some other file systems. , which also went successful. But I am not able to restore anything from the tape , from where I need to restore the data , even though It displays the Index file information in the tape without any issues.

I don't think that the problem could be due to the media, because the backup on that tape went success without any issues , but the restoration of the files are getting failed after throwing out the error as mentioned above after a long time ( around 50 mins ) of command execution.

Can anyone tell me , what could be the issues or Do I need to use any config file for the frecover util for restoration ?

your valuable suggestions are always welcome..

Thanks

Bijoy


3 REPLIES
Johnson Punniyalingam
Honored Contributor

Re: Restoration of Data backup fails........

Well are you root user ..? Could be Bad Media tape

could you please Check the status of the tape-drive using cstm command,

Problems are common to all, but attitude makes the difference
Md. Farhan A Azam
Trusted Contributor

Re: Restoration of Data backup fails........

Hi,

Share the output of below commands.

#mt -f /dev/rmt/0m status
#mt -f /dev/rmt/0m rew

in SAM which tape device file u r using.

Try to take backup through fbackup command & restore through frecover....share the output
unixguy_1
Regular Advisor

Re: Restoration of Data backup fails........


Hi Bijoyk,

There is no problm is in Media and drive, i thing the problem is in permission to take a backup.

So check the writes.

Check and revert back.