cancel
Showing results for 
Search instead for 
Did you mean: 

SAP INSTALLATION

 
wayne_104
Regular Advisor

SAP INSTALLATION

Hi
The sap consultant has requested the following to be placed on the system. Has anyone heard of this why such an old java version?

HPUX (Sun) Java version 1.4.2.26, as referred to in the attached SAP note 716926

and unlimited jurisdiction policy file, see note 146759

unlimited jurisdiction policy file, see note 146759

SAP Note 716926 - Recommendations for the HP JDK
Note Language: English Version: 37 Validity: Valid Since 09.12.2010
Summary
Symptom
Recommended Versions and Memory and JVM Settings for HPs JVMs for upgrading
and running WebAS 630/640/700 JavaEngine
Other terms
Out of Memory Permsize Heap Stability JDK JVM Version
Reason and Prerequisites
This note is valid for HP-UX on PA-Risc and Itanium. All recommendations
are valid for both architectures unless specified otherwise.
Solution
The recommended version is 1.4.2.26, which contains the latest
corrections.
You can download the SDK on http://www.hp.com/go/java. This page also
provides a list of required HP-UX patches for the SDK. Please make sure
that all required OS patches are installed. One can find the patches which
have to be additionally installed by selecting the currently installed
quality pack in the table entry corresponding to the exact OS and Java
versions on the following page (more detailed instructions are available
there too):
http://www.hp.com/products1/unix/java/patches/index.html.
Additionally please take care of note 837670, which contains the minimum
HP-UX patches required to install and run a SAP system.
If you need JCE policy files please have a look at SAP note 1426759.
For the "Java parameters" follow the recommendations in Note 723909.
If you find parameter -Djava.compiler=NONE please remove this line from
the settings.
Important notes for special HP J2SE versions:
With 1.4.2.20 a problem with the Solution Manager Diagnostics Agent occurs.
Please take care of SAP note 1301397.
Using Kerberos with a version older than 1.4.2.20 requires the workaround
described in SAP note 1233948.
Header
3 REPLIES
RickT_1
Valued Contributor

Re: SAP INSTALLATION

Wayne,

What version of SAP are you using?

Rick
Pete Randall
Outstanding Contributor

Re: SAP INSTALLATION

Usually requirements like that are the *minimum*. Ask your SAS consultant to clarify.


Pete

Pete
Alzhy
Honored Contributor

Re: SAP INSTALLATION

Wayne,

Always Follow what the vendor asks of ya or yer asking for trouble.

Now if you're wondering why the ancient Java 1.4 requirement despite Sun's edict of havibng 1. EOL'd a long time ago -- well, certain OS and software vendors still do maintain to support nd security levels versions of older Java 1.4 and Java 1.5 to meet ISV requirements. And HP still updates Java 1.4 it seems. We're in the same boar actually.
Hakuna Matata.