System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Stop PAM message from sshd (Secure Shell)

 
George Spencer_4
Frequent Advisor

Stop PAM message from sshd (Secure Shell)

On a number of our HP systems, an ssh connection correctly updates the u_suclog field in the tcb database; but not on others. The fault was found to be in the sshd_config on the newer versions of sshd (Secure Shell).
When the "# UsePAM yes" line is uncommented, the PAM modules are activated, and the u_suclog field in the tcb database is updated for ssh connections.

An unfortunate side-effect of activating the PAM modules, is that the users now see a message:
"Using keyboard-interactive authentication."
between the banner and the password prompt.

Is there a means of turning off this message, without recompiling sshd? The PAM manuals suggest that messages can be disabled by recompiling an application with the PAM_SILENT flag. However, this is definitely not my preferred option. Any suggestions?