System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Superblock could not be read on file systems

Superblock could not be read on file systems

Hello all,

We have a rx2660 with MSA Mod30 disk array running RHEL4 AS. We recently lost a couple of disks out of the array and had to replace them. I was able to add the disks back using mdadm -a and both remirrored back up. I did notice after losing the two disks that the original device configuration changed in the MD. However, after adding the disk back it went back to it's original configuration. Now I'm unable to mount the filesystem disks in the MD. I receive the following error when trying to mount the disks.
"The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock: e2fsck -b 8193

[Failed]"
I tried running the e2fsck -b 8193 command but with no success. These are uvol disks only, the root disk are under hardware raid.
1 REPLY

Re: Superblock could not be read on file systems

I forgot to mention that all the user file systems MD1 - MD14 are giving the same error.