Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
cancel
Showing results for 
Search instead for 
Did you mean: 

TFTP service

SOLVED
Go to solution
HP-UX_Ali
Regular Advisor

TFTP service

Hi All,

After disabling tftp service new connections not happening but my question is xisting process still can be seen & also port is listening
#netstat -a |grep -i tftp
udp 0 0 *.tftp *.*
i have added entry tftp deny in /var/adm/inetd.sec

I understand there will be no connections but i would like to clarify what is to be done for not listening to port (tftp).

Regards
9 REPLIES
Ganesan R
Honored Contributor

Re: TFTP service

Hi ALI,

If you want to disable particular service not to listen, disable the service on /etc/services file
Best wishes,

Ganesh.
Horia Chirculescu
Honored Contributor

Re: TFTP service

Hello,

tftpd is started usually from inted. Did you disabled the corresponding line from inted.conf and re-configured inetd (inetd -c)?

For the existing connections you must kill the running daemon (tftpd)

Horia.
Best regards from Romania,
Horia.
Steven Schweda
Honored Contributor

Re: TFTP service

> [...] disable the service on /etc/services
> file

Please stop offering this defective advice.
Leave "/etc/services" in peace.

> After disabling tftp service [...]

HOW? Rather than tell us what you hope that
you did, it might help to tell us what you
actually did. As usual, showing actual
commands with their actual output can be more
helpful than vague descriptions and interpretations.
Horia Chirculescu
Honored Contributor

Re: TFTP service

A typo... inted -> inetd

>if you want to disable particular service not to listen, disable the service on /etc/services file

Commenting out any line from /etc/services it is a bad habit.

Also, commenting out the very same line could or could not disable the service from starting.

/etc/services it is only a mapper of ports and protocols into service names.

Horia.
Best regards from Romania,
Horia.
HP-UX_Ali
Regular Advisor

Re: TFTP service

Hi Steven

>HOW? Rather than tell us what you hope that
you did

If you have seen my question thoroughly u should have understood.
i have mentioned.
"i have added entry tftp deny in /var/adm/inetd.sec"

And my question is once we disabled tftp service after running #netstat -a |grep -i tftp
i am getting output "udp 0 0 *.tftp *.*"

what can be done to disable listining of tftp service?

Thanks to confirm....

Horia Chirculescu
Honored Contributor
Solution

Re: TFTP service

>i have mentioned.
"i have added entry tftp deny in /var/adm/inetd.sec"

This does not mean that you actually disabled the tftpd daemon.

You only stopped new connections through inetd on tftp server. But if your tftpd server is still running or it is not even started from inetd (yes, tftpd can be started also outside of inetd as a stand alone service), your actions would have no effect on new connections

To actually disable the service you must comment the corresponding line from /etc/inetd.conf (put a # in fromt of it) if tftpd is started from inetd.


Best regards,
Horia.
Best regards from Romania,
Horia.
HP-UX_Ali
Regular Advisor

Re: TFTP service

Thanks Horia

Apprciate your response, checked & found OK.
Full marks :)

Thanks
Ali
HP-UX_Ali
Regular Advisor

Re: TFTP service

I have found the solution and hence closing the thread....
Steven Schweda
Honored Contributor

Re: TFTP service

> >i have mentioned.
> "i have added entry tftp deny in /var/adm/inetd.sec"
>
> This does not mean that you actually disabled the tftpd daemon.

Hence my confusion, and request for accurate
information.

> To actually disable the service [...]

Kicking inetd after editing its configuration
file can be helpful, too.

man inetd

Look for "-c".