System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to update BL p-classs chassis firmware

Tom Ward_1
Honored Contributor

Trying to update BL p-classs chassis firmware

I am new to blades and so far finding them frustrating. I have f/w 2.30 and need to move to 2.40.

I'm told that cpqblru it the tool for Lunux. I have installed it on two Suse 9 blades and one RedHat 4 blade then stage the firmware sj02_40rt.bin from SP36448.EXE on the blades. In call cases "cpqblru -a sj02_40rt.bin" comes back immediately with no output. Running the command with -v2 gives the same result. Md5sum on the bin file matches.

[root@localhost update]# cpqblru -v2 -l sj02_40rt.bin
[root@localhost update]# echo $?
244
[root@localhost update]# ls -l sj02_40rt.bin
-rw-r--r-- 1 root root 427436 Jul 12 23:59 sj02_40rt.bin

Any ideas?

hpasmd is running BTW.
[root@localhost log]# ps -ef |grep hpasmd
root 4622 1 0 00:11 ? 00:00:02 hpasmd


3 REPLIES
Sameer_Nirmal
Honored Contributor

Re: Trying to update BL p-classs chassis firmware

Maybe this customer advisory will help.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01202980〈=en&cc=us&taskId=101&prodSeriesId=3454580&prodTypeId=15351
Tom Ward_1
Honored Contributor

Re: Trying to update BL p-classs chassis firmware

Hi Sameer,

That first bullet point sure sounds like what's happening. I have installed the latest utilities from HP via a compress tar archive.

psp-8.20.sles9.i686.en.tar.gz

This was suggested by an HP backline engineer after I ran into conflicts with hpasm and hprsm. Hprsm requires hpasm, but when hpasm was installed hprsm refused to install due to file conflicts with hpasm.

rpm -ivh hprsm-7.9.0-108.sles9.i586.rpm
Preparing... ########################################### [100%]
file /opt/compaq/server/bin/cmarackd from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /opt/compaq/server/bin/cmasm2d from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /opt/compaq/server/etc/cmarackd from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /sbin/cpqblru from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /sbin/cpqriisd from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /usr/lib/libcpqipmb.so.1.0 from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /usr/share/man/man4/cpqblru.4.gz from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9
file /usr/share/man/man4/cpqriisd.4.gz from install of hprsm-7.9.0-108.sles9 conflicts with file from package hpasm-8.0.0-173.sles9

Any idea why that would happen? The install docs for hprsm lists a dependent package of hpasm.
Tom Ward_1
Honored Contributor

Re: Trying to update BL p-classs chassis firmware

I think the utilities do not work with Suse 9. HP came out and upgraded the firmware by connecting directly to the chassis.-