System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

hpacucli on Ubuntu 14.04 trusty

SOLVED
Go to solution
JamesJames
Advisor

hpacucli on Ubuntu 14.04 trusty

Hi,

 

installed Ubuntu 14.04 trusty without issues on a DL360p Gen8. Adding "deb http://downloads.linux.hp.com//SDR/downloads/ManagementComponentPack trusty/current non-free" to the sources.list results in 404 errors during apt-get update since HP doesn't provide hpacucli to the current Ubuntu LTS version. Is this planned?

 

Since apparently precise is the newest Ubuntu version in the repo I changed trusty to precise and installed hpacucli Version HP Array Configuration Utility CLI 9.40.12.0

If I run it I get an error:

 

root@hostname:~# hpacucli ctrl slot=0 pd all show

Smart Array P420i in Slot 0 (Embedded)  

APPLICATION UPGRADE REQUIRED: This controller has been configured with a more
                              recent version of software.
                              To prevent data loss, configuration changes to
                              this controller are not allowed.
                              Please upgrade to the latest version to be able
                              to continue to configure this controller.

 

According to the iLO I have HP Smart Array P420i Controller Firmware Version 4.68.

 

What is the issue here?

210983749817234712093
6 REPLIES
smartrak
Occasional Visitor

Re: hpacucli on Ubuntu 14.04 trusty

I've installed http://downloads.linux.hp.com/SDR/downloads/MCP/ubuntu/pool/non-free/hpacucli_9.40.1-1._amd64.deb on our new servers, they have P420i with "Firmware Version: 5.42".

 

I don't get the warning you are seeing when I run any of the raid commands.

 

Maybe you need to update the raid firmware? (contrary to the error of course!)

JamesJames
Advisor

Re: hpacucli on Ubuntu 14.04 trusty

Thanks, but for me it still doesn't work.

I ran the Firmware upgrade DVD which updated P420i Controller Firmware from 4.68 to 5.22 and installed hpacucli 9.40.1-1 via the deb file. Still got the same error mentioned above. Then I upgraded to the newest Controller Firmware 5.42 and still have the same error. Hpacucli shows me this version:

 

root@servername:~# hpacucli version

   ACU CLI Version: 9.40.12.0
   SoulAPI Version: 6.2.25.0

210983749817234712093
YosiA
Occasional Visitor

Re: hpacucli on Ubuntu 14.04 trusty

Im getting the same error on 12.04, but for me the problem is with SSD drive installed on the server.  When removing the SSD the probelm solved.

That's a problem becouse half of our servers have SSD and cant be monitor with hpacucli.

JamesJames
Advisor
Solution

Re: hpacucli on Ubuntu 14.04 trusty

alright, hpssacli works fine on ubuntu 14.04 - seems like hpacucli is discontinued and hpssacli is the successor

210983749817234712093
vgasu-vrn-ru
Occasional Visitor

Re: hpacucli on Ubuntu 14.04 trusty

Working version

 

sudo -i

echo 'deb http://downloads.linux.hp.com/SDR/repo/mcp trusty/current non-free' > /etc/apt/sources.list.d/hp.list

echo 'deb http://downloads.linux.hp.com/SDR/repo/mcp precise/current non-free' >> /etc/apt/sources.list.d/hp.list

wget -q http://downloads.linux.hp.com/SDR/repo/mcp/GPG-KEY-mcp -O - | apt-key add -

aptitude update

aptitude --target-release precise install hpacucli

 

Zootje
Occasional Visitor

Re: hpacucli on Ubuntu 14.04 trusty

Err http://downloads.linux.hp.com trusty/current Release.gpg
Could not resolve 'PLEASE.USE.NEW.HOSTNAME___downloads.linux.HPE.com___'
Err http://downloads.linux.hp.com precise/current Release.gpg
Could not resolve 'PLEASE.USE.NEW.HOSTNAME___downloads.linux.HPE.com___'

There is missing an 'e' in hpe.com

After getting these messages when running aptitude update I changed the sources (in /etc/apt/ directory to:

deb http://downloads.linux.hpe.com/SDR/repo/mcp trusty/current non-free
deb http://downloads.linux.hpe.com/SDR/repo/mcp precise/current non-free

These worked fine.

Also to get the GPG key to avoid messages about untrusted packages use this URL:

wget -q http://downloads.linux.hpe.com/SDR/repo/mcp/GPG-KEY-mcp -O - | apt-key add -

-Robert Roossien
http://details.nl