System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

hpasmcli not working after update to Debian Jessie 8.7

SOLVED
Go to solution
FidelityWorks
Occasional Visitor

hpasmcli not working after update to Debian Jessie 8.7

After performing an update on a ProLiant DL180 G6 server from Debian Wheezy to Debian Jessie the hpasmcli stopped working.

I receive the following error:

 

# hpasmcli

ERROR: Failed to get SMBIOS system ID.
This does not seem to be the HP Proliant Server that you are looking for.
ERROR: hpasmcli only runs on HPE Proliant Servers.

 

I tried removing the package and installing it again but didn't help.

dmidecode gives the following information

# dmidecode -t 1
# dmidecode 2.12
SMBIOS 2.6 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: HP
        Product Name: ProLiant DL180 G6
        Version:
        Serial Number: xxxx
        UUID: xxxx
        Wake-up Type: Power Switch
        SKU Number: xxxx
        Family:

Could the problem be that Family field is empty? How can I get more info regarding the issue?

 

1 REPLY
FidelityWorks
Occasional Visitor
Solution

Re: hpasmcli not working after update to Debian Jessie 8.7

Managed to make it work by installing the previous version which seems to be compatible with DL180 (I also installed the previous version of hp-snmp-agents to have snmp working):

apt-get remove hp-health hp-snmp-agents
apt-get install hp-snmp-agents=10.0.0.1.23-21. hp-health=10.0.0.1.3-4.
/etc/init.d/hp-snmp-agents restart
/etc/init.d/hp-health restart

and then I locked the versions to avoid accidental update

apt-mark hold hp-health
apt-mark hold hp-snmp-agents