HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

idle Java processes fail to respond under ARIES

 
Raymond E. Lilly
Frequent Advisor

idle Java processes fail to respond under ARIES

I am testing a PA-RISC application with ARIES on a new, fully patched B.11.31 U ia64 server. The first roadblock I run into is with hung Java processes. The processes start fine, but once the application sits idle for a few hours the java processes don't respond. By "don't respond" I mean I can no longer stop/start or query them with the application like I can before they sat idle.

On the PA-RISK platform this application runs with either the Java 1.3 version that gets installed along with the application (a Progress Software Company application) or the Java1.3 found in /opt.

I've tried everything on the Itanium machine that I can think of, including NFS mounts to the PA-RISC java1.3 binaries. No luck. A query request either hangs and does nothing or hangs, pegs a CPU at 100% and does nothing. I've also tried running the application with the Itanium's java1.4, but the application won't even start (Error accessing message #7021956244000743775).

It appears that ARIES emulation fails to maintain the necessary Java code after a period time. There are several Aries/jvm related posts that appear to touch on similar issues. Are there any workarounds or troubleshooting tricks I can try?
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: idle Java processes fail to respond under ARIES

Shalom,

go to http://www.hp.com/go/java and install the latest java release that will work.

Don't run java over NFS.

Make sure recommended java patches are installed from the above website.

Consider re-compiling your application native, because AIRES in real world tests exacts a 70% performance penalty.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Raymond E. Lilly
Frequent Advisor

Re: idle Java processes fail to respond under ARIES

The latest java release that will work for this application is JVM1.3.1 but this version is not available on the Itanium. Is there another way to accomplish this?

Re: idle Java processes fail to respond under ARIES

Please raise a support call with HP response center to troubleshoot rhe same. Thanks.
Raymond E. Lilly
Frequent Advisor

Re: idle Java processes fail to respond under ARIES

Thanks to all who replied.

After further testing I was able to find a PA-RISC Java that did not hang in my specific ARIES environment. Unfortunately it's a higher version than my application can use. I'll take this one up with HP technical support.

For reference - in order to test several versions in succession I found it easiest to install / patch Java directly on PA-RISC to the version I wanted and just copy the install folder over to the Itanium machine.

The first one I found that did not hang with ARIES was java version "1.4.2.09", but YMMV.

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2.09-050713-03:34)
Java HotSpot(TM) Server VM (build 1.4.2 1.4.2.09-050713-05:46-PA_RISC2.0 PA2.0 (
aCC_AP), mixed mode)