HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

keyboard backspace problem

 
aamir4u
Regular Advisor

keyboard backspace problem

hi,

 

when i press backspace the keyboard

its not delete the line or words

when i press SHIFT+backspace its deletes

 

it is possible only press backspace delete words or line whithout press SHIFT.

 

(i access the servers remotly via PUTTY(ssh))

 

Thanks   

Thanks
aamir uddin
4 REPLIES

Re: keyboard backspace problem

>when I press backspace the keyboard its not delete the line or words

 

Backspace only deletes one char.  Why would you want it to do more?

I think control-W deletes a word but I never use it.

 

And the KILL character will delete the whole line.  (See stty for yours.)

Bill Hassell
Honored Contributor

Re: keyboard backspace problem

PuTTY has a very poor default for the key to erase one character -- it is the DELETE key. Now for Tru64/VMS and other DEC variants, this is perfectly acceptable, but for the rest of us, PuTTY must be reconfigured. It's the first change needed among several.In the PuTTY config menu:

 

Terminal ---> Keyboard ---> The Backspace Key ---> Control-H    
   (was Control-?, the DELETE key)

 So while we're at it, let's fix all the other settings for a more useful terminal emulator:

 

Session ---> Close Window on Exit: Always

  Window  ---> Columns: 132  Rows: 48
    (your choice, but 80 is too small for logs and ioscan)

Lines of Scrollback  ---> 50000

  Appearance  ---> Cursor appearance: Block
                           Cursor blinks

  Font: Lucida Console, 10-point
    (or Courier, personal choice, 10 point or adjust to fit screen size)

  Font quality: Clear Type

  Colours: Font default is gray!! (182, not 255)
    Set Foreground = 255 255 255
    Set Background = personal choice
    (note: Bold = 255, so bold enhancements
     will be the same)

 

 



Bill Hassell, sysadmin
aamir4u
Regular Advisor

Re: keyboard backspace problem

Thanks for great advice.

 

But I want to simple delete word or character via BACKSPACE key.

 

is any setting on PUTTY or HP-UX OS.

 

Thanks

Thanks
aamir uddin
basant
Frequent Advisor

Re: keyboard backspace problem

This is the setting of Putty , Use latest version of putty & do the following setting in putty
Terminal ---> Keyboard ---> The Backspace Key ---> Backspace key in Keyboard. by default it is set Ctrl+h to delete a character ,. But you can change it to backspace.
Basant Sharma