System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

pls help: can't boot after root vg failure

S.T. Wong
Occasional Advisor

pls help: can't boot after root vg failure

Hi all,

We're running HPUX 11.0 on an L1000. The root VG has 2 disks mirrored. One day the primary disk failed 'partially' (vgdisplay -v shows some LV are staled but can be mounted). After engineer replaced the faulty disk (no change in VG configuration), the system can't boot. We find the root and boot filesystems are corrupted and can't be fsck'd. We then install minimal OS on a new disk on the same system, boot up and fix the failed root VG:
- vgimport the failed root VG as vg01
- break mirror of all lv
- vgreduce the faulty primary disk from the root vg
- mkfs root and /stand filesystems, and restore data from tape.
- perform lvlnboot to setup root, boot, swap, and dump.
- mv /stand/rootconf /stand/rootconf.org
- vgexport

All these steps can complete without error.
However, when we try to boot the original root vg (with only 1 disk inside), the boot process failed after setting up dump area. The console has error messages popped up but with "no problem detail" displayed. Then system tried to dump and reboot. Same result no matter we support any combination of "-lm -lq -iS".

I think we've some important step missed.

Besides, when I tried to run chroot_lvmdisk in recovery disk, I always can't get through as the fsck cNtNdNs2lvm always fails. Seems it takes the 2nd lv as root but we've following setting (default ?):

lvol1 /stand
lvol2 swap
lvol3 /

I tried recovery CD of 11.0, 11iv1 and 11iv2. All failed with same problem.

Would anyone please help? Thanks a lot.

/ST Wong
2 REPLIES
Mel Burslan
Honored Contributor

Re: pls help: can't boot after root vg failure

A screen capture of the console would help understanding where exactly your boot sequence is failing but if you can explain the last few lines, before the servers decides to core dump and reboot, suggestions can be more meaningful.

If the dump starts while the system is loading the kernel, it means that while building the system, something went wrong and a faulty kernel got generated.

If the system is dumping, while it id going through the rc.scripts (you know lines with lots of dots on them) then you can look for the guilty party, which was being executed just before system decides go belly up.

If you can provide more details where and how this crash takes place, I am sure better answers will come.
________________________________
UNIX because I majored in cryptology...
S.T. Wong
Occasional Advisor

Re: pls help: can't boot after root vg failure

Hi,

Here comes screen dumps when the system boot. The boot process 'stops' after "Swap device table: (start & size givin in 512-byte blocks)". See boot1.jpg attached. Seems it's not frozen as pressing enter can scroll up the screen. After around half minute, alert message pops up (see boot2.jpg attached). The system dumps and reboot after acknowledging the alert messages.

Thanks a lot.
/ST Wong