problems with NTP

 
SOLVED
Go to solution
Karin Willems
Advisor

problems with NTP

I have a Cisco 4506 as a NTP server.
I can start the ntpserver and then it runs for a while (2 -3 minutes)

# ntpq -p
remote refid st t when poll reach delay offset disp
==============================================================================
c4506a.hln.ict4 gw1.ict4.net 3 u 45 64 17 1.01 -353409 1878.62
c4506b.hln.ict4 gw1.ict4.net 3 u 45 64 17 0.87 -353409 1880.19

And then.... it dies quietly and I get this message:
# ntpq -p
ntpq: read: Can't assign requested address

Can anyone tell me what causes this?

Thx

Karin

9 REPLIES 9
Mark Greene_1
Honored Contributor

Re: problems with NTP

what do you get when you do this:

# ntpq

ntpq>associations

ntpq>pstatus [assID from command above]


mark
the future will be a lot like now, only later
paolo barila
Valued Contributor

Re: problems with NTP

Hi,
try this thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=995591

[Admin:The above link is not longer valid]

share share share
Asif Sharif
Honored Contributor

Re: problems with NTP

Hi Karin,

I think that your firewall is blocking UDP port 123 or 125 . As it is a NTP client you must be specifying the server or hostname in your /etc/ntp.conf file also.

Regards,
Asif Sharif
Regards,
Asif Sharif
Karin Willems
Advisor

Re: problems with NTP

Hi Mark,

after I started NTP I get this:

# ntpq
ntpq> associations
ind assID status conf reach auth condition last_event cnt
===========================================================
1 36804 8000 yes no
2 36805 8000 yes no
ntpq> pstatus 36804
status=9014 reach, conf, 1 event, event_reach
srcadr=c4506a.hln.ict4.net, srcport=123, dstadr=172.30.33.1,
dstport=123, keyid=0, stratum=3, precision=-18, rootdelay=62.68,
rootdispersion=21.48, refid=gw1.ict4.net,
reftime=c7b15933.8ae4b8d9 Thu, Mar 2 2006 11:44:51.542,
delay= 1.04, offset= -3636606.47, dispersion=15875.02, reach=001,
valid=0, hmode=3, pmode=4, hpoll=6, ppoll=6, leap=00, flash=0x0,
org=c7b15946.27757ed0 Thu, Mar 2 2006 11:45:10.154,
rec=c7b1677a.c2d93000 Thu, Mar 2 2006 12:45:46.761,
xmt=c7b1677a.c294e000 Thu, Mar 2 2006 12:45:46.760,
filtdelay= 1.04 0.00 0.00 0.00 0.00 0.00 0.00 0.00,
filtoffset=-3636606.48 0.00 0.00 0.00 0.00 0.00 0.00 0.00,
filterror= 0.02 16000.00 16000.00 16000.00 16000.00 16000.00 16000.00 16000.0
ntpq> pstatus 36805
status=9014 reach, conf, 1 event, event_reach
srcadr=c4506b.hln.ict4.net, srcport=123, dstadr=172.30.33.1,
dstport=123, keyid=0, stratum=3, precision=-18, rootdelay=59.72,
rootdispersion=31.14, refid=gw1.ict4.net,
reftime=c7b15761.49de4a7d Thu, Mar 2 2006 11:37:05.288,
delay= 0.90, offset= -3636605.63, dispersion=15875.02, reach=001,
valid=0, hmode=3, pmode=4, hpoll=6, ppoll=6, leap=00, flash=0x0,
org=c7b15946.27ad1e85 Thu, Mar 2 2006 11:45:10.154,
rec=c7b1677a.c2d57000 Thu, Mar 2 2006 12:45:46.761,
xmt=c7b1677a.c29a6000 Thu, Mar 2 2006 12:45:46.760,
filtdelay= 0.90 0.00 0.00 0.00 0.00 0.00 0.00 0.00,
filtoffset=-3636605.64 0.00 0.00 0.00 0.00 0.00 0.00 0.00,
filterror= 0.02 16000.00 16000.00 16000.00 16000.00 16000.00 16000.00 16000.0
ntpq>


After a few minutes I tried again (without exiting ntpq!):
ntpq> associations
ntpq: read: Can't assign requested address


Bill Hassell
Honored Contributor
Solution

Re: problems with NTP

From ntpq -p, it appears that you are using 2 NTP servers, the Cisco boxes (a good choice):

c4506a.hln.ict4 gw1.ict4.net 3 u 45 64 17 1.01 -353409 1878.62
c4506b.hln.ict4 gw1.ict4.net 3 u 45 64 17 0.87 -353409 1880.19

However, the offset is extremely high (353409). The suggestion is to jump-sync the clock on your local system at a time when applications are not running (or reboot). However, the error message (can't assign requested address) indicates that another process is using the NTP port. The most common error is running ntpdate in cron (an archaic method to maintain the timeclock). The correct way is to use xntpd to adjust the clock (slowly) all the time (every 64 to 1024 seconds). Remove any ntpdate entries in cron or other scripts and enable NTP in /etc/rc.config.d/netdaemons. Then search for any processes that are using port 123. lsof (you'll need to download this) can find them for you. kill these prcesses, then stop and restart xntpd with:

/sbin/init.d/xntpd stop
/sbin/init.d/xntpd start

Then check syslog regularly:

grep ntp /var/adm/syslog/syslog.log


Bill Hassell, sysadmin
Karin Willems
Advisor

Re: problems with NTP

Hi everyone,

Yesterday I've solved it. I first used ntpdate and started ntp. Now it is still running. So thanks a lot everybody.

Bye

Karin
paolo barila
Valued Contributor

Re: problems with NTP

Hi,

where are our points then?

Pablo
share share share
Karin Willems
Advisor

Re: problems with NTP

I'm sorry, it's the first time I'm using this forum. It won't happen again !
Tyates27
Occasional Contributor

Re: problems with NTP

I am still struggling with this issue and cant get it to budge.

any insight will be appreciated.

Tom