System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

remote printers automatically disable

SOLVED
Go to solution
Bram Vermeulen
Regular Advisor

remote printers automatically disable

Greetings,

Our remote printers automatically disable everytime we enable them. We have 2 remote printers, both have these problems. We work with HP-UX 11.23.

Turning the printer on and off, removing and readding the printer, restarting the spooler, clearing the printer queue, restarting the printserver all do not help.

Here's some more information I looked up based on previous threads with this error:

BHPUX01 root /usr/sbin> lpstat -plp4
printer lp4 disabled since Dec 30 15:59 -
error 1 returned
fence priority : 0

BHPUX01 root /usr/sbin> ls -l rlp
-rwxrwxr-x 1 root lp 88788 Dec 2 2004 rlp
this used to be:
-r-sr-xr-- 1 root lp 88788 Dec 2 2004 rlp
but I changed the mode because somebody on another thread had a similar problem and that was adviced. This file is from 2 December 2004 while I saw other people have it from 2007. However I haven't filed another version of this executable.

When I restart the spooler the printer always seems busy for a while, but after a while it automatically disabled.
In SAM:
lp4 remote yes, busy yes pr1 on lp4

Through lpstat -plp4 after restarting the spooler:
printer lp4 now sending lp4-7399 to lp4. enabled since Dec 30 16:09
fence priority : 0

Through lpstat -t:
printer queue for lp4
no entries

BHPUX01: sending to lp4
But nothing is being printed, after a while it just gets disabled.

Is there anything else I should try? Anybody know how this problem exists?
It are line printers so I cannot turn them into network printers with JetDirect or anything.

4 REPLIES
Bram Vermeulen
Regular Advisor

Re: remote printers automatically disable

Something I should add.
After trying restarting the print server, restarting the spooler, etc. for several times the printer starts working for a while. But after a couple of days the same problem arises. Given it takes me atleast 2 hours everytime to restart everything several times and testing if it works this time I guess I don't have to say it's pretty annoying. :)

Thanks in advance.
James R. Ferguson
Acclaimed Contributor
Solution

Re: remote printers automatically disable

Hi Bram:

The permissions change you made eliminated the 'setuid' bit to always run 'rlp' executable as 'root'.

As for the last modification timestamp's, you appear to have a version from your installation DVD/CD rather than a patched variant.

I suggest that you download and install patch PHCO_36976. No reboot is required and it does rectify a number of problems with the remote line printer daemon.

Regards!

...JRF...
Matti_Kurkela
Honored Contributor

Re: remote printers automatically disable

Check the print spooler log: /var/adm/lp/log.

The printer may get disabled because the spooler cannot connect to the print server (the print server does not respond, or responds with an error). If you have problems in network connectivity, this may cause the printer to become disabled.

What exactly is the print server (the "lp4")?
The actual line printer seems to be known as "pr1 on lp4".

Some cheap print server boxes don't work too well if more than one computer is attempting to spool data to them simultaneously. The remote printer protocol is not well suited for diskless print servers.

For example, if computer A and computer B attempt to spool a print job, and computer A gets its job in first, a cheap spooler might completely ignore the connection from computer B until it times out. This will cause the print queue on computer B to become disabled until the sysadmin re-enables it.

A better spooler accepts the connection from computer B and uses some tricks to delay accepting the incoming data until the printer is free. The best spooler is a real computer with some disk space, so it can immediately accept the new job even though the printer is busy printing the previous one.

To work around this problem, set up one computer as a "central spooler" for this printer and allow only that machine to access the print server (lp4) directly. The central spooler machine should have plenty of disk space so that it can hold multiple jobs waiting for the printer to become free.

MK
MK
Bram Vermeulen
Regular Advisor

Re: remote printers automatically disable

I installed the patch and took note of the fact that these print server boxes might not work well. I won't be able to check up if the patch fixed it finally because this is my last day at this job (starting a new job next year), pointed my co-workers to this thread so they could read it if the problem persists.

Thanks for the advice!