System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

sftp of large files from Linux fails

 
SOLVED
Go to solution
MikeL_4
Super Advisor

sftp of large files from Linux fails

We are running Red Hat 5.6 and have a client trying to sftp a file from our Linux server to another client... When they try larger files, 1 - 2G they stall and fail...
If they try sending the same file from a Solaris server to this same location it works....

ran sftp with -v option, if anyone can lend a helping hand on where to look....


=> sftp -v v0000cvg@199.19.240.205
Connecting to 199.19.240.205...
OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
debug1: Reading configuration data /etc/ssh/ssh_config

debug1: Applying options for *

debug1: Connecting to 199.19.240.205 [199.19.240.205] port 22.

debug1: Connection established.

debug1: identity file /home/infawci/.ssh/id_rsa type 1

debug1: identity file /home/infawci/.ssh/id_dsa type -1

debug1: loaded 2 keys

debug1: Remote protocol version 2.0, remote software version 1.82_sshlib GlobalSCAPE

debug1: no match: 1.82_sshlib GlobalSCAPE

debug1: Enabling compatibility mode for protocol 2.0

debug1: Local version string SSH-2.0-OpenSSH_4.3

debug1: SSH2_MSG_KEXINIT sent

debug1: SSH2_MSG_KEXINIT received

debug1: kex: server->client aes128-cbc hmac-md5 none

debug1: kex: client->server aes128-cbc hmac-md5 none

debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP

debug1: SSH2_MSG_KEX_DH_GEX_INIT sent

debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY

debug1: Host '199.19.240.205' is known and matches the RSA host key.

debug1: Found key in /home/infawci/.ssh/known_hosts:62

debug1: ssh_rsa_verify: signature correct

debug1: SSH2_MSG_NEWKEYS sent

debug1: expecting SSH2_MSG_NEWKEYS

debug1: SSH2_MSG_NEWKEYS received

debug1: SSH2_MSG_SERVICE_REQUEST sent

debug1: SSH2_MSG_SERVICE_ACCEPT received

EFT Server Enterprise 6.2.18 Build 09.08.2010.3debug1: Authentications that can continue: publickey,password

debug1: Next authentication method: publickey

debug1: Offering public key: /home/infawci/.ssh/id_rsa

debug1: Server accepts key: pkalg ssh-rsa blen 277

debug1: read PEM private key done: type RSA

debug1: Authentication succeeded (publickey).

debug1: channel 0: new [client-session]

debug1: Entering interactive session.

debug1: Sending environment.

debug1: Sending env LANG = en_US.UTF-8

debug1: Sending subsystem: sftp

sftp> cd dualusage/Incoming/extracts

sftp> put DUPLICATE_TESTING_SFTP_LARGE_FILES_PLEASE_DELETE

Uploading DUPLICATE_TESTING_SFTP_LARGE_FILES_PLEASE_DELETE to /dualusage/Incoming/extracts/DUPLICATE_TESTING_SFTP_LARGE_FILES_PLEASE_DELETE

DUPLICATE_TESTING_SFTP_LARGE_FILES_PLEASE_DELETE 11% 140MB 115.8KB/s - stalled -debug1: channel 0: free: client-session, nchannels 1

debug1: fd 0 clearing O_NONBLOCK

Read from remote host 199.19.240.205: Connection reset by peer

debug1: Transferred: stdin 0, stdout 0, stderr 64 bytes in 162.2 seconds

debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 0.4

debug1: Exit status -1

Couldn't send packet: Connection reset by peer

SIT-1 infawci@:
3 REPLIES 3
Matti_Kurkela
Honored Contributor
Solution

Re: sftp of large files from Linux fails

> debug1: Remote protocol version 2.0, remote software version 1.82_sshlib GlobalSCAPE

> EFT Server Enterprise 6.2.18 Build 09.08.2010.3debug1

Hmm, this looks like the remote side has some commercial implementation of SSH... Googling for those key words reveals the server is probably "EFT Server" from the makers of Windows software CuteFTP.

The newest version of EFT Server is 6.3, and one of its new features is "support for >2GB files", which sort of implies version 6.2 does not have that feature:

http://www.globalscape.com/eft/whatsnew.aspx

But if that was the problem, I would expect the transfer to stall either at the very beginning, or when the transferred data size reaches 2 GB, so there might be something else going on.

> Read from remote host 199.19.240.205: Connection reset by peer

> Couldn't send packet: Connection reset by peer

This looks like the host 199.19.240.205 suddenly terminated the connection without any explanation. (It might also be caused by an overly-aggressive firewall somewhere between the hosts.)

Do you have access to the logs of the SSH server at 199.19.240.205? Since it looks like the server is cutting the connection, the server's logs might explain what's going wrong.

MK
MK
Highlighted
MikeL_4
Super Advisor

Re: sftp of large files from Linux fails

I have not been able to get hold of the client at the remote site to get there logs, etc.. or have the network firewall checked, but I have been playing with different options on sftp and noticed that if I use the compressed option: -C the transmission succeeds...

I've tried this now about a dozen times without failure....
Alan_152
Honored Contributor

Re: sftp of large files from Linux fails

Have you tried scp as an alternative?