HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

some windows client got problem to access samba server

 
kenken_3
Regular Advisor

some windows client got problem to access samba server

Hi,

I just setup a new samba server on hpux11.11 and I try to list the service from the server itself and another unix server, everything looks fine.

however, some of my windows client got some problem to access the samba server. here is I got from the connection logs:

[2009/08/29 00:23:13, 1] smbd/service.c:make_connection_snum(642)
cliet IP (server IP) connect to service export initially as user guest (uid=109, gid=105) (pid 10932)
[2009/08/29 00:23:13, 1] smbd/service.c:close_cnum(829)
client IP (server IP) closed connection to service export.

below is my smb.conf file
========================================
# Global parameters
[global]
workgroup = BO
server string = server(Samba Server)
security = SHARE
encrypt passwords = Yes
log file = /var/opt/samba/log.%m
max log size = 1000
local master = No
guest account = guest
read only = No

[homes]
comment = Home Directories
browseable = No

[export]
path = /export/
guest ok = Yes
browseable = Yes
#hosts allow = 11.192.243.15

====================================

it seems it connects and closes the connction quickly.

Anyone could help? thanks
wang & wang
1 REPLY
kenken_3
Regular Advisor

Re: some windows client got problem to access samba server

Hi,

After enabled debug level 10 logging from the samba end, I captured some error message like this:

2009/08/31 18:39:39, 10] lib/util_sock.c:receive_smb_raw(556)

receive_smb_raw: length < 0!

[2009/08/31 18:39:39, 3] smbd/process.c:timeout_processing(1346)

timeout_processing: End of file from client (client has disconnected).

It seems something has triggered the connection to close after the connection is established. I asked help from Samba webiste, but they said our samba versions is still 3.0 and they don't support it any more. However, our latest HP version is still A.02.04 (3.0k).

Anyone knows where I could some help on this? it seems there are some application level issues in the samba.

thanks,
ken
wang & wang