cancel
Showing results for 
Search instead for 
Did you mean: 

swinstall & AMDSP commands

SOLVED
Go to solution
David Dangerfield_1
Frequent Advisor

swinstall & AMDSP commands

I had an N-Class server with FC60 Storage attached that we just did an OS install to version 11.23 we installed all the software and patches. But now when i do a swinstall i get the following:

"ptdsvr1:": You do not have permission for this operation. The
depot owner, system administrator, or alternate root owner may need
to use the "swreg" or "swacl" command to give you permission. Or, to
manage applications designed and packaged for nonprivileged mode, see
the "run_as_superuser" option in the "sd" man page.

Also when i try to setup my fc60 i get the following:

The AM60Srvr did not respond. It may not be running or it may still be
in the process of initializing.
6 REPLIES
Mel Burslan
Honored Contributor
Solution

Re: swinstall & AMDSP commands

the two issues do not seem to be related and since FC storage arrays are so much in the past, I do not even remember any details about them anymore so, sorry, no help there.

when it comes to your swinstall issue, I think a simple restart of swagentd can help you:

# swagentd -r

hope this helps
________________________________
UNIX because I majored in cryptology...
David Dangerfield_1
Frequent Advisor

Re: swinstall & AMDSP commands

Unfortunately that swagentd -r didn't help.
Bob E Campbell
Honored Contributor

Re: swinstall & AMDSP commands

Please show the full install command and make sure you are running as the root user.
Steven E. Protter
Exalted Contributor

Re: swinstall & AMDSP commands

Shalom,

This operation must be done as root

There must be an /etc/nsswitch.conf file present on the system.

The swagentd daemon must be running use

ps -ef | grep swagent

To make sure the daemon is running.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: swinstall & AMDSP commands


"You do not have permission for this operation" reply may cause from the rights at /var/adm/sw/security/_ACL.
Modify it like that.

/var/adm/sw/security#cat _ACL
# default_realm=servername
any_other:rw---

Torsten.
Acclaimed Contributor

Re: swinstall & AMDSP commands

If swinstall **and** AM60Srvr are not working correctly, you maybe have a general network problem, e.g. name resolution. You should check this.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!