cancel
Showing results for 
Search instead for 
Did you mean: 

/tmp size

SOLVED
Go to solution
rianui
Trusted Contributor

/tmp size


Hello Experts,

Just a quick one. When I did an installation of HP-UX 11i V2 on an rx7640 I specified the /tmp file system to be 5GB. Why? It would be comfortable during installation of other software when we have big files to transfer or unzip. Also, there is plenty of hard drive space.
Now when I run the 'bdf' command, I get the folling output:

/dev/vg00/lvol5 2097152 16816 2064224 1% /tmp


In SAM, under logical volumes, I can see that /tmp actually has 5GB:

lvol5 vg00 LVM VxFS 5008 1 /tmp

How does this work? Shoudn't I be able to see the whole size as the rest when I run bdf?

Kind Regards,

Rinaui
5 REPLIES
Jeeshan
Honored Contributor

Re: /tmp size

during installation did you mention the /tmp file system in "Fixed size"?

check the lvol size from vgdisplay output.
a warrior never quits
Matti_Kurkela
Honored Contributor
Solution

Re: /tmp size

I think the lvol may be 5 GB in size, but the filesystem on it is not configured to use the full size. The situation is essentially the same as with a "half-done" LV extension: the "lvextend" step was successful, but "extendfs" or "fsadm" step was missing or incomplete.

Maybe you managed to find a bug/limit in HP-UX installer...

If the problem is what it seems to be, it should be easy to fix.

First, use "lvdisplay /dev/vg00/lvol5" to confirm the LV size. It should say 5008 megabytes. (I'm a command-line guy, I don't even remember the structure of the SAM views by heart! :-)

If you have OnlineJFS installed, just run "fsadm -F vxfs -b 5008m /tmp" and you're done.

If OnlineJFS is not available, you'll have to unmount /tmp and run "extendfs -F vxfs /dev/vg00/lvol5". You may have to reboot the system into single-user mode first: unmounting /tmp may be difficult otherwise.

MK
MK
rianui
Trusted Contributor

Re: /tmp size

Hi again,

Ahsan, I had used a script to do the installation...which I actually hadn't written :(
Were it an advanced installation then I could have been able to answer that correctly. Thank you for you time.
Matti, I have succeeded after running the command you suggested. I appreciate your help a lot. Here is the bdf output now:

/dev/vg00/lvol5 5128192 16912 5071488 0% /tmp


Thanks and Regards,

Rianui
rianui
Trusted Contributor

Re: /tmp size

I have found a solution for the question I had asked.

Thank You!
Avinash20
Honored Contributor

Re: /tmp size

Check with
# lvdisplay /dev/vg00/lvol5
Check the
LV Size (Mbytes)

>>> This should match with bdf output

NOTE: bdf will show in KB while lvdisplay displays size in MB

If its different, then you might have run lvextend, but forgot to run extendfs

lvextend extends the LV while extendfs extends the filesytem which you could see in bdf output

to run extendfs you need to boot the server into single user mode in case if OnlineJFS product is not installed
"Light travels faster than sound. That's why some people appear bright until you hear them speak."