Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Procurve 2530 sh mac-address return nothing

 
Highlighted
Regular Advisor

Procurve 2530 sh mac-address return nothing

I have a device connected to Port 1 (I can see it in GUI)

SW-SwimPool-2530-24G-PoE# sh mac-address 1

 Status and Counters - Port Address Table - 1

  MAC Address   VLANs
  ------------- ------------

Yet I can not get its MAC displayed

arp also return no directly attached devices (true, majority are dumb devices, like AP/network sounders/cameras)

But to have nothin displayed is pants!

7 REPLIES 7
Highlighted

Re: Procurve 2530 sh mac-address return nothing

Hello, 

A layer 2 switch will by default not display arp information about directly connected devices. It uses MAC addresses for forwarding dicisions and doesnt need IP to mac mappings (arp entries). Only a L3 switch or router should have the IPs in the arp table and only for this clients which need their traffic to be routed. A layer2 switch configured for authentication can use the feature ip client-tracker but this switch doesnt support it.

End device that support LLDP can also provide information to the switch via LLDP TLVs. You can use the command show lldp info remote on the switch to check which devices sent LLDP information.

But of course the mac-address should be visible in the mac-address table if the device sent at least one packet trough the switch in the last 5 minutes. The entry will age out and be removed if no packet was received in the last 5 minutes. So please make sure that the attached end device is active and sending traffic through the switch.

Check with the command show interface 1 is the interface is UP or DOWN. 

Check with show mac-address (without specifying port) if the mac address appeares on another port. Maybe the cable was attached to another port by mistake.

Maybe you can also provide the output of show running-config, so we can check if something in the configuration may affect the mac-learning.

 

I am an HPE employee

Accept or Kudo


Highlighted
Regular Advisor

Re: Procurve 2530 sh mac-address return nothing

I do NOT care about IP, I need MAC address to physical port relation

 

I have ~ 15 live ports on the switch.

sh mac-address shows 5 devices on port 27 (which is uplink port)

It shows NONE of the devices on the switch itself!

Highlighted

Re: Procurve 2530 sh mac-address return nothing

Hello,

Please save to text files the outputs of the commands 

show mac-address

show tech all

Upload the outputs to ftp://es341720:!KH3nz.R@ftp.ext.hpe.com

let me know once done!

I am an HPE employee

Accept or Kudo


Highlighted
Regular Advisor

Re: Procurve 2530 sh mac-address return nothing

Done, none of the devices on VLAN15 (Port1-10) even connected do show on it

Highlighted

Re: Procurve 2530 sh mac-address return nothing

Hello, 

Thanks for the data!

You are correct. No mac-addresses were learned on ports 1 to 10. But if you scroll down in the text file to the output of show interfaces all and check the counters of this ports, you will see that Unicast Rx is showing 0. Here is port 1.

 

Status and Counters - Port Counters for port 1

Name :
MAC Address : 00fd45-9ba41f
Link Status : Up
Port Enabled : Yes
Totals (Since boot or last clear) :
Bytes Rx : 1,947 Bytes Tx : 573,145,070
Unicast Rx : 0 Unicast Tx : 15,526
Bcast/Mcast Rx : 0 Bcast/Mcast Tx : 4,245,884
Errors (Since boot or last clear) :
FCS Rx : 3 Drops Tx : 0
Alignment Rx : 0 Collisions Tx : 0
Runts Rx : 0 Late Colln Tx : 0
Giants Rx : 0 Excessive Colln : 0
Total Rx Errors : 3 Deferred Tx : 0
Others (Since boot or last clear) :
Discard Rx : 0 Out Queue Len : 0
Unknown Protos : 0
Rates (5 minute weighted average) :
Total Rx (bps) : 0 Total Tx (bps) : 33,024
Unicast Rx (Pkts/sec) : 0 Unicast Tx (Pkts/sec) : 0
B/Mcast Rx (Pkts/sec) : 0 B/Mcast Tx (Pkts/sec) : 27
Utilization Rx : 0 % Utilization Tx : 00.03 %

The only packets that the switch received on thsi port were 3 packets with FCS errors. FCS (Frame check sequence) errors indicate that the packets were corrupted during transmission. This frames are dropped and the switch will not learn MAC addresses using the source MAC of this frame.

Exactly the same situation with the other ports in the range 1 to 10 which are up at the moment, 1, 2, 4, 8, 10. The interesting thing is that this device (except port 10) are receiving PoE power from the switch.

The VLAN 15 is called "appliances", are the devices connected to VLAN 15 exactly of the same type and model? 

I think it would be helpful if you can do a cross test in order to determine if the issue is caused by the switch or not. You can unplugg the device from port 1 and plug a laptop or another known working device there. Check again if the MAC address is learned and Unicast is received.

Or you can take one of the devices on the functioning ports in the range 11 -24 and swapp it with the device on port 1. Adjust the VLAN membership and check how it is working. If the appliance from port 1 still doesnt work on port 11 for example (where we know that MAC e43022-0cf5c4 was learned) and device e43022-0cf5c4 from port 11 is working fine on port 1  then it should be a problem with the appliance.

Alternatively you could check if this devices are working on the 2930 with IP 10.0.1.60 or some of the Extreme switches.

I am not sure how you can troubleshoot the appliances. FCS could mean a bad cable, bad NIC, duplex mismatch.

Feel free to upload a new show tech all and show mac-ad if you are not sure how to interpret the results of a cross test.

I am an HPE employee

Accept or Kudo


Highlighted
Regular Advisor

Re: Procurve 2530 sh mac-address return nothing

To start, I am under lockdown (same as most of the world), so can not remotely swap anything from port to port.

Devices on Vlan 15 are live & accessible (they are CCTV cameras and network sounders). There is nothing bad about any of it (device, cable,patch)

I do have the same behaviour on 2920 switches

I just needed to check remotely which port one of my odd Raspberry Pi applience is connected (I cannot ping it, so either somebody moved it to a wrong port - unlikely, or it just "dropped dead" - strange, because it should be in port 10 & it looks like it is still connected)

 

Seb

Re: Procurve 2530 sh mac-address return nothing

Hello, 

Sorry, I was assuming that the devices in VLAN 15 are not working at all. If they are live and accessible then something should be wrong with the management interface of the switch. I see that the switch was rebooted 2 days ago. Did you reboot it in an attempt to resolve this issue? I am not sure if something can be done remotely. You can try to clear the mac table, disable and re-enable ports, things you probably already tried. The best thing would be to open a support case once you are back in the office.

I am an HPE employee

Accept or Kudo