BladeSystem - General
Showing results for 
Search instead for 
Did you mean: 

DHCP for OA but not for Device Bays

Trusted Contributor

DHCP for OA but not for Device Bays

Chris had a customer issue with getting IP addresses using the DHCP server:



Had an enclosure with static OA IP address and static IP addresses configured via EBIPA for each blade iLO processor.  Was forced to change the IP subnet of the OA and now the OA is obtaining its IP address via DHCP.  Disabled EBIPA for the device bays and reset cycled the OA modules expecting the device bays to obtain IP address via DHCP.  There is a DHCP server providing the address to OA.  How can we configure the iLO for each server to obtain the IP address via DHCP?  Tried to enable/disable EBIPA a couple of times with OA recycles in between - no success.  Not sure what we are doing wrong. 


Unfortunately this is OA version 2.20 (working on getting the customer to update).



Monty had some suggestions:



EBIPA support for server blade iLO 2 is dependent upon both the OA FW version and iLO 2 FW version – you didn’t mention the iLO 2 FW version.


We have changed the DHCP lease time for the device bays and later versions of OA firmware attempt to reset the iLO network stack to have it get an updated IP address quickly.


I suspect that these lease time changes, and reset iLO network when EBIPA configuration is changed for a device bay are not in the OA v2.20 release – and the iLO 2 may wait a long time for the lease to expire.


Have you tried using the OA CLI “connect server” command to access the iLO 2?  It sounds like with the OA reporting no IP address – that no network access is working to those iLO.


Unless you can access the iLO GUI or CLI, then the only way to remotely reset the iLO is using the OA CLI “reset server” command.  Since the iLO is configured for DHCP (from when you used EBIPA), resetting the server will result in the iLO obtaining a fresh IP address from the external DHCP server – although it will take that server offline during the power cycle.



Have you had issues using DHCP and getting IP addresses for iLO? Let us know.

New Member

Re: DHCP for OA but not for Device Bays

A reference would be most useful for the various commands in the iLO serial UI, it's pretty cryptic to try to figure out how to enable DHCP.  I appear to have a fixed IP, and resetting the server does not change the static address shown by "show server list".  I can now ping the iLO address by setting a static route to the switch, but still can't get to the web UI, apparently because traffic is "filtered", but I don't see anything in the serial port that gets me to the iLO network configuration.


Any pointers would be most appreciated.