BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

hponcfg xml errors when attempting to disable IPMI

 
Highlighted
Occasional Advisor

hponcfg xml errors when attempting to disable IPMI

It's ILO version 2 and I get this error on both firmware 2.27 and 2.29

 

> hponcfg 9 << EOF

<RIBCL VERSION="2.0">
<LOGIN USER_LOGIN="Administrator" PASSWORD="changeme">
<RIB_INFO MODE="write">
<MOD_GLOBAL_SETTINGS>
<IPMI_DCMI_OVER_LAN_ENABLED VALUE="No"/>
</MOD_GLOBAL_SETTINGS>
</RIB_INFO>
</LOGIN>
</RIBCL>
EOF

Bay 9: Awaiting RIBCL results ...
Bay 9: Executing RIBCL request ...
Bay 9: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 9: RIBCL results retrieved.
<!-- ======== START RIBCL RESULTS ======== -->


<!-- ======== Bay 9 RIBCL results ======== -->

Error writing xml_header

<!-- ======== END RIBCL RESULTS ======== -->

11 REPLIES 11
Highlighted
Honored Contributor

Re: hponcfg xml errors when attempting to disable IPMI

From the Lights Out XML scripting sample package it appears that command does not work with iLO2

<RIBCL VERSION="2.0">
   <LOGIN USER_LOGIN="adminname" PASSWORD="password">
      <RIB_INFO MODE="write">
         <MOD_GLOBAL_SETTINGS>
             <!--      iLO 4 - 1.20 or later.                       -->
              <!--      iLO 3 - 1.55 or later.                       -->
              <!--      iLO 2 - None.                                -->
            <IPMI_DCMI_OVER_LAN_ENABLED value="n"/>
         </MOD_GLOBAL_SETTINGS>
      </RIB_INFO>
   </LOGIN>
</RIBCL>

 

 

No support by private messages. Please ask the forum! 
Highlighted
Occasional Advisor

Re: hponcfg xml errors when attempting to disable IPMI

So we can't using hponcfg with xml to make changes on ilo2 blades?

Highlighted
Honored Contributor

Re: hponcfg xml errors when attempting to disable IPMI


@billeverhart wrote:

So we can't using hponcfg with xml to make changes on ilo2 blades?


No, the element <IPMI_DCMI_OVER_LAN_ENABLED value="n"/> isn't supported on iLO2

No support by private messages. Please ask the forum! 
Highlighted
Occasional Advisor

Re: hponcfg xml errors when attempting to disable IPMI

That element was added to ilo2 in 2.23.  When I run the command on < 2.23 I see ipmi option not found, but when I update to 2.27 which should have ipmi, I get the xml_handler error. I got the same error on 2.27 when I tried to add an ilo user.

Highlighted
Occasional Advisor

Re: hponcfg xml errors when attempting to disable IPMI

I can even see the option to disable ipmi in the ilo web interface, I just cant seem to disable it using xml.

Highlighted
Honored Contributor

Re: hponcfg xml errors when attempting to disable IPMI

the example mod_global_settings is where it states no for iLO2, maybe old text before it was added in 2.23, or maybe the XML just doesn't work for that option on iLO2.  I have passed your error over to the iLO group.

No support by private messages. Please ask the forum! 
Highlighted
Honored Contributor

Re: hponcfg xml errors when attempting to disable IPMI

I just used cpqlocfg.exe 4.21 to send the below script to my iLO2 2.29 and it worked.

 

<RIBCL VERSION="2.0">
 <LOGIN USER_LOGIN="adminname" PASSWORD="password">
  <RIB_INFO MODE="write">
   <MOD_GLOBAL_SETTINGS>
    <IPMI_DCMI_OVER_LAN_ENABLED value="n"/>
   </MOD_GLOBAL_SETTINGS>
  </RIB_INFO>
 </LOGIN>
</RIBCL>

 

Could it be something with the hponcfg.exe tool you are using?




__________________________________________________
If you feel this was helpful please click the KUDOS! thumb below!
Highlighted
Occasional Advisor

Re: hponcfg xml errors when attempting to disable IPMI

I'm using the hponcfg tool that's on the onboard administrator.

Highlighted
Occasional Advisor

Re: hponcfg xml errors when attempting to disable IPMI

I'm seeing the exact same error on ilo4's as well:

 

> hponcfg ALL << EOF
<RIBCL VERSION="2.0">
<LOGIN USER_LOGIN="caastage\everhwt1" PASSWORD="1Car:0l0000018">
<RIB_INFO MODE="write">
<MOD_GLOBAL_SETTINGS>
<IPMI_DCMI_OVER_LAN_ENABLED value="n"/>
</MOD_GLOBAL_SETTINGS>
</RIB_INFO>
</LOGIN>
</RIBCL>
EOF

Bay 4: The blade is not present.
Bay 5: The blade is not present.
Bay 6: The blade is not present.
Bay 7: The blade is not present.
Bay 8: The blade is not present.
Bay 12: The blade is not present.
Bay 13: The blade is not present.
Bay 14: The blade is not present.
Bay 15: The blade is not present.
Bay 16: The blade is not present.
Bay 1: Awaiting RIBCL results ...
Bay 3: Executing RIBCL request ...
Bay 11: Executing RIBCL request ...
Bay 1: Executing RIBCL request ...
Bay 9: Executing RIBCL request ...
Bay 2: Executing RIBCL request ...
Bay 10: Executing RIBCL request ...
Bay 1: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 1: RIBCL results retrieved.
Bay 9: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 2: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 11: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 10: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 3: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 2: Awaiting RIBCL results ...
Bay 2: RIBCL results retrieved.
Bay 3: Awaiting RIBCL results ...
Bay 3: RIBCL results retrieved.
Bay 9: Awaiting RIBCL results ...
Bay 9: RIBCL results retrieved.
Bay 10: Awaiting RIBCL results ...
Bay 10: RIBCL results retrieved.
Bay 11: Awaiting RIBCL results ...
Bay 11: RIBCL results retrieved.
<!-- ======== START RIBCL RESULTS ======== -->


<!-- ======== Bay 1 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 2 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 3 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 9 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 10 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 11 RIBCL results ======== -->

Error writing xml_header

<!-- ======== END RIBCL RESULTS ======== -->


bwi40g-c7000-16corg8m-000-oa1> hponcfg ALL << EOF
<RIBCL VERSION="2.0">
<LOGIN USER_LOGIN="Administrator" PASSWORD="password">
<RIB_INFO MODE="write">
<MOD_GLOBAL_SETTINGS>
<IPMI_DCMI_OVER_LAN_ENABLED value="n"/>
</MOD_GLOBAL_SETTINGS>
</RIB_INFO>
</LOGIN>
</RIBCL>
EOF

Bay 4: The blade is not present.
Bay 5: The blade is not present.
Bay 6: The blade is not present.
Bay 7: The blade is not present.
Bay 8: The blade is not present.
Bay 12: The blade is not present.
Bay 13: The blade is not present.
Bay 14: The blade is not present.
Bay 15: The blade is not present.
Bay 16: The blade is not present.
Bay 9: Executing RIBCL request ...
Bay 2: Executing RIBCL request ...
Bay 10: Executing RIBCL request ...
Bay 3: Executing RIBCL request ...
Bay 1: Executing RIBCL request ...
Bay 1: Awaiting RIBCL results ...
Bay 11: Executing RIBCL request ...
Bay 9: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 2: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 10: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 1: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 3: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 1: RIBCL results retrieved.
Bay 11: An error occurred while executing the script on iLO. Please review the RIBCL results.
Bay 2: Awaiting RIBCL results ...
Bay 2: RIBCL results retrieved.
Bay 3: Awaiting RIBCL results ...
Bay 3: RIBCL results retrieved.
Bay 9: Awaiting RIBCL results ...
Bay 9: RIBCL results retrieved.
Bay 10: Awaiting RIBCL results ...
Bay 10: RIBCL results retrieved.
Bay 11: Awaiting RIBCL results ...
Bay 11: RIBCL results retrieved.
<!-- ======== START RIBCL RESULTS ======== -->


<!-- ======== Bay 1 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 2 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 3 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 9 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 10 RIBCL results ======== -->

Error writing xml_header

<!-- ======== Bay 11 RIBCL results ======== -->

Error writing xml_header

<!-- ======== END RIBCL RESULTS ======== -->