Comware Based
Showing results for 
Search instead for 
Did you mean: 

7500/7900 switching fabric corrupt?


7500/7900 switching fabric corrupt?



I have a 384Gbps Switcihgin Fabric Module with 2 XFP Ports.  When booting it is not displaying the boot menu, just a load of what look like errors (below).  Anyone seen this or have any ideas?  I'm wondering if the flash is corrupt but I'd still get the boot menu right?  Bootrom corrupt?  Is there any way of reflashing or reconfiguring when in a none boot state and no access to the boot menu?


Press Ctrl+D to access BASIC BOOT MENU
Press Ctrl+T to start memory test s0 = FFFFFFFFDFA6FFE8,  s1 = FFFFFFFFDFF7FDF8,  gp = FFFFFFFFDFEA98D0, epc = FFFFFFFFDFE745C8,  cause = 0000000000008030,  status = 0000000000400002
                CP0_ERROREPC = FFFFFFFFBFC01390
                                                CP 0 Registers:
                                                                CP0_INDEX       = FFFFFFFFDFE745C8
                                                                                                        CP0_RANDOM      = 000000000000003F
                                                                                                                                                CP0_ENTRYLO0    = 0000000002380027
                CP0_ENTRYLO1    = 00000000023C0027
                                                        CP0_CONF        = 00000000023C0027
                                                                                                CP0_CONTEXT     = C37F9367B6800000
                                                                                                                                        CP0_PAGEMASK    = 0000000001FFE000
        CP0_WIRED       = 000000000000003F
                                                CP0_INFO        = 0000000000000013
                                                                                        CP0_BADVADDR    = 0000000000000246
                                                                                                                                CP0_COUNT       = FFFFFFFFBF0C3688
                                                                                                                                                                       CP0_ENTRYHI     = C0000FFFDE000000
                                        CP0_COMPARE     = 0000000000000000
                                                                                CP0_STATUS      = 0000000000400002
                                                                                                                        CP0_CAUSE       = 0000000000008030
                                                                                                                                                                CP0_EPC         = FFFFFFFFDFE745C8
                                CP0_PRID        = 0000000000040103
                                                                        CP0_CONFIG      = FFFFFFFF8000C08B
                                                                                                                CP0_LLADDR      = 0000009E2A2850EB
                                                                                                                                                        CP0_WATCHLO     = 0000000000000000
                        CP0_WATCHHI     = FFFFFFFF80000000
                                                                CP0_XCONTEXT    = 0CD45EE000000000
                                                                                                        CP0_FRAMEMASK   = 000000000007B65F
                                                                                                                                                CP0_DIAGNOSTIC  = FFFFFFFFFFFFFFFC
                CP0_DEBUG       = 000000002000B800
                                                        CP0_PERFORMANCE = FFFFFFFF80000200
                                                                                                CP0_ECC         = 0000000000000000
                                                                                                                                        CP0_CACHEERR    = 00000000140012A0
        CP0_TAGLO       = 0000000000000000
                                                CP0_TAGHI       = 0000000000000000
                                                                                        CP0_ERROREPC    = FFFFFFFFBFC01390


After this it just sits there doing nothing further...  Hope someone out there can help...

Respected Contributor

Re: 7500/7900 switching fabric corrupt?

Hi rafter

Are you pressing CTRL-D to get the menu?


If you are, and still not getting the menu - then...


You could try some lowlevel trial and error options, like

 - Removing (if any installed) all linecards

 - Reseat the MPU

 - Try a different chassis if you have one.


 Other than that, you have a status "status = 0000000000400002", caused by

"cause = 0000000000008030". And some other coprocessor0 register values,  which are all part of the MIPS exeption handling.  You can convert these to binary and  you can google around to get wiser on that - but I'd start looking into my RMA-options on the MPU.



Søren Dideriksen, Network Administrator
Region Midtjylland

Re: 7500/7900 switching fabric corrupt?

Thanks Soren for the response.


I have managed to get into the menu some of the times, although when I dont the errors are as I've posted, although the cause I've also seen FFFFFFFF80008014.


When I have managed to get into the menu, I have successfully formated the flash and put the latest .app on, but when it boots it freezes at random points.  I've also had it freeze just in the menu too.  When it displays a dump I have to leave it out a while then reseat it and hope I have another go!


This is a slave card for another identical card that is working at present.  I've tried in another chassis without success too..


Any ideas where I can find out what these codes mean?



Trusted Contributor

Re: 7500/7900 switching fabric corrupt?

Call HP for a RMA, they should be able to guide you over the phone if this can be fixed (with some proper keyboard commands) or if the unit is bricked and needs to get replaced.

Respected Contributor

Re: 7500/7900 switching fabric corrupt?

Hi Rafter,


The MIPS64 architechture can be googled and found various places i reckon, e.g:


in there you can read about exception handling, the coprocessor,  etc ... so if you have some time on your hands its quite interesting -

Still tho - go for the RMA.



Søren Dideriksen, Network Administrator
Region Midtjylland