cancel
Showing results for 
Search instead for 
Did you mean: 

Disks won't stop at shutdown

 
Highlighted
Occasional Advisor

Disks won't stop at shutdown

I've just loaded Linux FC2 onto an old Proliant 1850R using a mirror array of 2x 9.1GB hot swap drives connected to the Smart array. When I shutdown everything succeeds until it reports that md0 has been set to read-only. After this the disk activity lights on both caddies go on even though the one under the power switch is off. The drives appear to remain active continuously and the machine won't power down or restart. I end up having to use the power switch and am concerned about interupting the disks whilst work is in progress. Is this normal, I've ensured that the Smart and System firmware are both up to date?

Many thanks in advance,
Tom
11 REPLIES 11
Highlighted
Occasional Advisor

Re: Disks won't stop at shutdown

I've just taken a closer look/listen and the disks are definitely working. The array diagnostics report no errors. What are the disks doing and how can I stop it?

Cheers,
Tom.
Highlighted
Respected Contributor

Re: Disks won't stop at shutdown

Did you config APM both linux driver nad BIOS ?
Highlighted
Occasional Advisor

Re: Disks won't stop at shutdown

Linux reports failure with APM. The System Config app on the 1850R doesn't seem to give me any APM or ACPI options to modify. Am I looking in the wrong area?

Cheers, Tom
Highlighted
Respected Contributor

Re: Disks won't stop at shutdown

Tell me first if you use CTL+ALt+DEL what happen ?
Highlighted
Occasional Advisor

Re: Disks won't stop at shutdown

I'm controlling it remotely using PuTTY over a SSH connection so I haven't tried Ctrl-Alt-Del. I have tried 'shutdown -h now' and 'shutdown -r now' both of which leave it in a state of unidentified disk activity.
I've decided to leave it soaking for the moment and see whether any of the Smart-2DH features are at work checking drive/RAID integrity. The confusing one is why would the drives indicate activity if the server lights don't? Also, how can ACPI/APM be configured using the Compaq System Config application and is this the only method of getting into the BIOS?
Its possible that it will eventually work itself out but having left it for 4.5 hours with no joy my next option will be to leave it semi-shutdown over the Christmas break and see whether five days is enough time!

Cheers, Tom.
Highlighted
Respected Contributor

Re: Disks won't stop at shutdown

I think that ATX power must switch box off .
Highlighted
Occasional Advisor

Re: Disks won't stop at shutdown

What do you mean by ATX Power? Do I need to configure this within System Configuration or within Linux?

Many thanks, Tom
Highlighted
Respected Contributor

Re: Disks won't stop at shutdown

I find that Fedora 2 have problem with power off. This is your problem.
But I can find why.

ATX- power supplay have feature that give you "software" way to switch your PC off.

http://www.fedoraforum.org/forum/archive/index.php/t-18278.html

http://www.fedoraforum.org/forum/showthread.php?t=25716

http://www.redhat.com/archives/fedora-list/2004-May/msg06163.html
Highlighted
Respected Contributor

Re: Disks won't stop at shutdown

Stop all power save and APM feature.