General
cancel
Showing results for 
Search instead for 
Did you mean: 

Eclipse build failded: Make: Must be a separator on

 
Highlighted
Advisor

Eclipse build failded: Make: Must be a separator on

Hello

i tried to build the eclipse source code on a HP-UX 11.11.

But this error displays:

[exec] Make: Must be a separator on rules line 26. Stop

I don't know what happend :-(

which makefile is it?

HP-UX 11.11
Eclipse Source 3.3.1.1
ant 1.7.0
java 6
gmake 3.80

Can anybody help me?

Thx
Thomas
6 REPLIES 6
Highlighted
Exalted Contributor

Re: Eclipse build failded: Make: Must be a separator on

Shalom,

Many open source products require code changes to work with HP-UX.

Eclipse is available at http://software.hp.com
Search for Internet Express.
Choose your OS, click in and pick eclipse.

No reason to compile it.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Highlighted
Advisor

Re: Eclipse build failded: Make: Must be a separator on

The problem was, that the version in the HPUX depot was to old :-(

it is a version from 2006 and i have troubles with the cdt plugin

thx for answer.
Highlighted
Honored Contributor

Re: Eclipse build failded: Make: Must be a separator on

Hello,

a) Internet Express contains latest version
of Eclipse for HP-UX 11.11:

Product #: HPUXIEXP1111
Version: A.10.00
Eclipse A.10.00-3.3.1
...

Did you use the latest version of IE?

b) As far as Eclipse build is concerned,
the following forum is helpful:

http://www.eclipsepowered.org/eclipse/forums

c) Your "make" problem (although we are
missing more details) is probably a result
of some Makefile issue in the source tree.

d) Finally, the current version is 3.4M4:

http://download.eclipse.org/eclipse/downloads/drops/S-3.4M4-200712131700/index.php

Cheers,

Vk2COT
VK2COT - Dusan Baljevic
Highlighted
Honored Contributor

Re: Eclipse build failded: Make: Must be a separator on

> [exec] Make: Must be a separator on rules line 26. Stop

> gmake 3.80

I know nothing, but if I were to guess, I'd
guess that you're really using a non-GNU
"make" program.

Some "make" files use "make" instead of
"$(MAKE)", which can lead to use of the wrong
"make" program, even if _you_ really did
specify GNU "make" (as, say, "gmake" or
"/usr/local/bin/make") in your initial build
command. In some cases, the easiest solution
is to define a PATH which finds GNU "make"
for a "make" command.

Many GNU developers seem to assume that
"make" is GNU "make", which probably works
better in a Linux environment than it does in
a typical commercial UNIX environment.
Highlighted
Acclaimed Contributor

Re: Eclipse build failded: Make: Must be a separator on

This error typically occurs because there isn't a tab at the beginning of the make rule.

Or as Steven said, you need gmake.
Highlighted
Advisor

Re: Eclipse build failded: Make: Must be a separator on

Dusan Baljevic:
a) that is right, but the internal versionnr is I20061102-1715

c)error message:
[exec] Make: Must be a separator on rules line 26. Stop

d) I build the 3.4M4 but the ./plugins/org.eclipse.rcp.source.hpux.motif.PA_RISC/src directory is missing.. now i try the 3.4M3

Steven Schweda:
I switched the link vom make to gmake and then the build (3.3.1.1) breaks at

[subant] Failure for target 'post.compile.@dot' of ....../customBuildCallbacks.xml
[subant] the following error occurred while executing this line:
[subant] customBuildCallbacks.xml:91: Error while expanding ..../ecj.jar
[exec] cc: 487: warning: Possibly incorrect message catalog

[exec] ../localfile.c:16 jni.h: NO such file or directory
[exec] In file included form ../localfile.c:22



JAVA_HOME=/opt/java6
CLASSPATH=/opt/jva6/lib

greetings
Thomas