cancel
Showing results for 
Search instead for 
Did you mean: 

Failed Write with Samba, NFS

 
Highlighted
New Member

Failed Write with Samba, NFS

Hi Folks,

I have some users that can't write to some directories, but can read from them. I've checked the permissions and they are good. It also seems this problem is intermittent.

In their samba logs:

["date", 0] smbd/quotas.c:hpux_nfs_quotas(989)
hpux_nfs_quotas: RPC clnt_create() failed, error:0 (Error 0)

Version info:

HP-UX 11.23
* B8725AA A.02.03.04 HP CIFS Server

swlist | grep -i nfs
PHCO_36930 1.0 Japanese NFS/LIBNSL manpages
PHCO_36931 1.0 Japanese NFS manpages
PHCO_36932 1.0 Japanese NFS/RCMDS manpages
PHCO_36933 1.0 Japanese NFS/NIS manpages
PHCO_36934 1.0 Japanese core NFS manpages
PHNE_36980 1.0 NFS cumulative patch

Entries in /etc/fstab are of the form:

: nfs nointr,retry=10,retrans=8,rsize=8192,wsize=8192
0 0

I'm also using samba with kerberos 5 for authentication. There are no quotas implemented on the samba server or NFS server.

Has anyone seen this error before?

Thanks
4 REPLIES 4
Highlighted
New Member

Re: Failed Write with Samba, NFS

Forgot, the samba server is only setup as an NFS client:

NFS_CLIENT=1
NFS_SERVER=0
NUM_NFSD=16
NUM_NFSIOD=16
PCNFS_SERVER=0
Highlighted
Respected Contributor

Re: Failed Write with Samba, NFS

Have not seen that error before. Most likely you have an NFS issue - you did not mention anything about the NFS server. In any case, sharing an NFS client mountpoint is generally discourage, although many people do it. Just to rule out Samba, do a "testparm -v -s | grep -i lock" and turn off whatever locking is set. You might also post the NFS client version, NFS server hp-ux version, and NFS server NFS version.

Eric Roseme
Hewlett-Packard

PS - you could put this thread in "networking".
Highlighted
New Member

Re: Failed Write with Samba, NFS

HP Software Support found the answer for me:

Make sure disk quotas are turned off. The default value is on. I was seeing the error above even though the NFS server and samba server didn't enable any kind of disk quotas. Example fix:

[homes]
# ... your stuff

# The default is "yes"
disk quotas = no

# ... your stuff

I'm not sure if "disk quotas =" is available in the globals section.
Highlighted
New Member

Re: Failed Write with Samba, NFS

Closed. See above post for solution.