HPE Primera Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

Expansion of HPE Smart Array P408i-a on gen10 running CentOS 7 not recognized

 
SOLVED
Go to solution
Highlighted
Occasional Contributor

Expansion of HPE Smart Array P408i-a on gen10 running CentOS 7 not recognized

Hello there,

Recently our technicians added a new 3.8TB disk to the Array. We were able to add the disk to the Logical drive 1 as follows:

 

ssacli ctrl slot=0 ld 1 add drives=allunassigned

 

Followed by

 

ssacli ctrl slot=0 ld 1 modify size=max

 

Subsequently we ran

 

ssacli rescan

 

Fortunately, the controller recognizes the new added disk to the logical drive but the Operating system CentOS Linux release 7.6.1810 (Core)  isn't able to recognize the new size of the block device.

ssacli

 

# ssacli ctrl slot=0 pd all show

HPE Smart Array P408i-a SR Gen10 in Slot 0 (Embedded)

   Array A

      physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SATA SSD, 3.8 TB, OK)
      physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SATA SSD, 3.8 TB, OK)
      physicaldrive 1I:1:3 (port 1I:box 1:bay 3, SATA SSD, 3.8 TB, OK)
      physicaldrive 1I:1:4 (port 1I:box 1:bay 4, SATA SSD, 3.8 TB, OK)
      physicaldrive 2I:1:5 (port 2I:box 1:bay 5, SATA SSD, 3.8 TB, OK)
      physicaldrive 2I:1:6 (port 2I:box 1:bay 6, SATA SSD, 3.8 TB, OK)
      physicaldrive 2I:1:7 (port 2I:box 1:bay 7, SATA SSD, 3.8 TB, OK)

# ssacli ctrl slot=0 ld all show

HPE Smart Array P408i-a SR Gen10 in Slot 0 (Embedded)

   Array A

      logicaldrive 1 (17.47 TB, RAID 6, OK)

 

then from OS perspective,

 

# lsblk
NAME             MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda                8:0    0   14T  0 disk 
├─sda1             8:1    0  200M  0 part /boot/efi
├─sda2             8:2    0    1G  0 part /boot
└─sda3             8:3    0   14T  0 part 
  ├─centos-root  253:0    0   50G  0 lvm  /
  ├─centos-swap  253:1    0  128G  0 lvm  [SWAP]
  └─centos-ovirt 253:2    0   10T  0 lvm  /storage/some/path

# blockdev --report /dev/sda
RO    RA   SSZ   BSZ   StartSec            Size   Device
rw  8192   512  4096          0  15362888654848   /dev/sda

 

I've tried partprobe and also partx, parted but to no avail.

 

# parted /dev/sda print
Model: HPE LOGICAL VOLUME (scsi)
Disk /dev/sda: 15.4TB
Sector size (logical/physical): 512B/8192B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  211MB   210MB   fat16        EFI System Partition  boot
 2      211MB   1285MB  1074MB  xfs
 3      1285MB  15.4TB  15.4TB                                     lvm

 

Note: I don't want to reboot the system.

Is there a way to force the OS to detect the new disk / logical drive geometry without rebooting the system?

Thanks in advance!

2 REPLIES 2
Highlighted
Honored Contributor
Solution

Re: Expansion of HPE Smart Array P408i-a on gen10 running CentOS 7 not recognized

Have you tried with a echo 1 > /sys/block/sda/device/rescan against sda to detect related changes?

I'm not an HPE Employee
Kudos and Accepted Solution banner
Highlighted
Occasional Contributor

Re: Expansion of HPE Smart Array P408i-a on gen10 running CentOS 7 not recognized

Hi pamassus,

THank you very much for your reply. That was indeed the fix! What I did try was

 

echo "- - -" >  /sys/class/scsi_host/host1/scan

 

but that did not help. Since it concerns a production system I was being extra careful and thought let's throw the question in here. 

Thanks agian and have a great day!