HPE SimpliVity
cancel
Showing results for 
Search instead for 
Did you mean: 

New SimpliVity Nodes: The installer does not have any compatible VC code in its configuration

 
SOLVED
Go to solution
Highlighted
Occasional Advisor

New SimpliVity Nodes: The installer does not have any compatible VC code in its configuration

Hello,

I'm trying to deploy new simplivity nodes with Omnistack version 3.7.10 into a federation which has nodes with Omnistack 3.7.8. I've upgraded the Arbiter and vShpere Plugin to match the ones in 3.7.10 software package and I've created a new VMware cluster to deploy the new nodes in it, I'm using 3.7.10 Deployment Manager and get this error once trying to deploy the new nodes:

step 4 of 34 (00.46%) - Hypervisor version request 6.5.0-s4
step 4 of 34 (00.46%) - Appropriate Hypervisor version found - version 6.5.0-s4
step 4 of 34 (00.46%) - Internal warning - Requested Virtual Controller version not found, looking for alternative - 3.7.8.232
step 4 of 34 (00.46%) - Getting VC Version: Trying 3.7.8 from 3.7.8.232
step 4 of 34 (00.46%) - Getting VC Version: Trying 3.7.8 for match with 3.7.10.200-release
step 4 of 34 (00.46%) - The installer does not have any compatible VC code in its configuration - 3.7.8.232

Any idea whats causing this? 

OmniStack version: 3.7.10.200
Arbiter version: 3.7.10.91
Windows vCenter Server version: 6.5.0 U2d
SimpliVity Plugin for vSphere version: 17.25.0

Thanks in advance

8 REPLIES 8
Highlighted
HPE Pro
Solution

Re: The installer does not have any compatible VC code in its configuration

Hello @Gaisu 

Thank you for using HPE SimpliVity Forums

You need to have at least one node running 3.7.10 in that new cluster to be able to directly deploy nodes in that version. What you can do is deploy the first node in that new cluster using 3.7.8 and update it to 3.7.10, then commit the update. 

After this you will be able to deploy nodes to that cluster directly to 3.7.10.

 

Hope it helps, 

-Gus

I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: The installer does not have any compatible VC code in its configuration

Hello Gus,

Thanks for the reply, I'll try that and get back to you.

but I wonder will the the new plugin work with the old nodes, cuz since I installed it some error message appeared in cVenter about the plugin cannot cummunicate with the OVC. 

Highlighted
HPE Pro

Re: The installer does not have any compatible VC code in its configuration

Are they HPE or legacy hardware ?


I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: The installer does not have any compatible VC code in its configuration

Hello Dave,

HPE Proliant DL380 Gen10 servers

Highlighted
HPE Pro

Re: The installer does not have any compatible VC code in its configuration

@Gaisu The plugin for 3.7.10 doesn't support flex version anymore so you may experience limited functionality with 3.7.8. If you don't plan to upgrade the rest of the federation then I'm thinking you might need two separate vCenters, one for each cluster so you can manage both. 

I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: The installer does not have any compatible VC code in its configuration

Hello Gus,

I've downgraded the node to 3.7.8, deplyed it and then upgraded it to 3.7.10 successfully, now when I'm trying to deploy other nodes I get the error: (step 31 of 34 (47.44%) - Failed to set ManagedBy extension on Virtual Controller)

step 31 of 34 (47.44%) - Configuring VC settings
Scheduling watchdog to fire in 500s
Created HMS task to set CPU reservations to 8776 MHz / high shares
step 31 of 34 (47.44%) - Configuring VC settings - Complete
step 31 of 34 (47.44%) - Checking if SVA has ManaagedBy extension set
step 31 of 34 (47.44%) - Set ManagedBy extension on Virtual Controller
Setting managedBy extension for the virtual machine 'OmniStackVC-10-11-29-163' with 1 retries
Created VMSetManagedByExtensionTask with key: com.simplivity.evalta, type: omnicube
Scheduling watchdog to fire in 120s
Created HMS task to set managedBy extension for virtual machine 'OmniStackVC-10-11-29-163'. Task id : 789c0e57-f3c2-44d9-9707-b06a7c4bb892:Task:task-3844
HMS task to set managedBy extension for virtual machine 'OmniStackVC-10-11-29-163' FAILED. Task id : 789c0e57-f3c2-44d9-9707-b06a7c4bb892:Task:task-3844.
Exception occurred while setting managedBy extension for - OmniStackVC-10-11-29-163
com.simplivity.hval.exceptions.HVALOperationFailedException: reconfigVM task failed: A specified parameter is not correct.

 

I've tried multiple nodes and all have the same error., is this related to the upgraded node or a different issue?

 

Highlighted
HPE Pro

Re: The installer does not have any compatible VC code in its configuration

@Gaisu When you upgraded to 3.7.10 did you commit the update. Were ESX software updates and firmware done as well?

I am an HPE employee
Accept or Kudo
Highlighted
Occasional Advisor

Re: The installer does not have any compatible VC code in its configuration

Hello @gustenar ,

Yes the update was commited, firmware was upgraded to 2019.301I didnt upgrade the esxi though since the vcenter is 6.5.0U2d and ESXi is 6.5.0U2c

Update:

After Restting the nodes and trying the deployment again it worked fine. Thanks alot for your help.