Showing results for 
Search instead for 
Did you mean: 

Loop Protection issue/question

Occasional Contributor

Loop Protection issue/question



We would like to implement Loop Protection on our HP switches on our LAN.


We started by testing with a 2510G-24 with a basic configuration:


; J9279A Configuration Editor; Created on release #Y.11.35


hostname "ProCurve Switch 2510G-24"

ip default-gateway

snmp-server community "public" Unrestricted

snmp-server host "public" All

vlan 1

   name "DEFAULT_VLAN"

   untagged 1-24

   ip address


loop-protect 1-24

loop-protect trap loop-detected

loop-protect disable-timer 15



We connected a dumb switch to one of the 2510 ports, then caused a loop on the dumb switch.  The 2510 immediately sensed the loop and disabled the port.  It would re-enable the port after 15 seconds and immediately disable the port again when it detected the loop was still there.  When we took out the loop, the port was re-enabled and stayed that way.  It worked exactly as expected.


We then connected another of the 2510 ports to our production LAN via a simple daisy-chain.  None of the other switches in the LAN have Loop Protect turned on.  With that connection in place, the Loop Protect no longer worked.  The test 2510 logs a "high broadcast" rate for the port with the looped-dumb-switch, but no longer detects the loop.  If we disconnect the cable to the production LAN, the Loop Protect works properly again.


What could cause the Loop Protect to fail when we are connected to our Production LAN?  Is there some protocol that could be overriding/suppressing Loop Protect on our test 2510 switch?


Thanks for any insight that you can provide on this issue.


Bryan Hunt