LAN Routing
cancel
Showing results for 
Search instead for 
Did you mean: 

Could somebody help me verify this HP switch configuration vs the Cisco source config?

 
Highlighted
New Member

Could somebody help me verify this HP switch configuration vs the Cisco source config?

Hi all, 

First time poster so please excuse me if this is the wrong place to post this but this is forum seemed the most appropriate.  

I am migrating a client from a Cisco L3 switch to an HP SG350 and I'm a bit new to the differences in HP configurations.  Can somebody tell me if I've successfully mimiced the functionality (specifically the VLANs) of the cisco config in the HP config below?   The only difference I purposely did was instead of trunking 44 and 45 like it is on the cisco switch, I'm splitting them out into separate interfaces since I'm also replacing the firewall and it has slightly different functionality that requires the connections to it to be access ports.  I added a mapping of old interface to new interface underneath the configurations to show what I did with those.  It only shows ports that are currently live on the cisco switch.  I've also removed any lines in the configs that are client specific.

Thanks for any advice

CISCO CONFIG

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2018.12.18 21:58:20 =~=~=~=~=~=~=~=~=~=~=~=

#show run
system mtu routing 1500
ip subnet-zero
ip routing
ip domain-name xxxxx.com
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-1001 priority 4096
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
description Printers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/2
description Printers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/3
description Printer 192.168.1.23
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/4
description Printers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/5
description Printers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/6
description Printers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 100
!
interface FastEthernet0/8
switchport access vlan 100
!
interface FastEthernet0/9
switchport access vlan 100
!
interface FastEthernet0/10
switchport access vlan 100
!
interface FastEthernet0/11
description Server/Printers 6160
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/12
description Servers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/13
description Servers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/14
description Servers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/15
description Servers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/16
description Servers
switchport access vlan 100
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 100
!
interface FastEthernet0/18
switchport access vlan 100
!
interface FastEthernet0/19
switchport access vlan 100
!
interface FastEthernet0/20
switchport access vlan 100
!
interface FastEthernet0/21
description WiFi cont 2504 .15
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/22
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/23
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/24
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/25
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/26
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/27
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/28
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/29
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/30
description WiFi APs
switchport access vlan 100
switchport trunk encapsulation dot1q
switchport trunk native vlan 100
switchport trunk allowed vlan 100,200
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/31
switchport access vlan 100
!
interface FastEthernet0/32
switchport access vlan 100
!
interface FastEthernet0/33
switchport access vlan 100
!
interface FastEthernet0/34
switchport access vlan 99
!
interface FastEthernet0/35
switchport access vlan 100
!
interface FastEthernet0/36
switchport access vlan 100
!
interface FastEthernet0/37
switchport access vlan 100
!
interface FastEthernet0/38
switchport access vlan 100
!
interface FastEthernet0/39
switchport access vlan 100
!
interface FastEthernet0/40
switchport access vlan 100
switchport mode access
!
interface FastEthernet0/41
switchport access vlan 100
!
interface FastEthernet0/42
description Inet Access 1
switchport access vlan 99
!
interface FastEthernet0/43
description Inet Backup
switchport access vlan 199
!
interface FastEthernet0/44
description FW outside Et0/0
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 99,199,999
switchport mode trunk
!
interface FastEthernet0/45
description FW inside Et0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 100,200,999
switchport mode trunk
!
interface FastEthernet0/46
switchport access vlan 99
switchport mode access
!
interface FastEthernet0/47
description Edgewater outside
switchport access vlan 99
!
interface FastEthernet0/48
description Link to SF300 Bridgewater
switchport access vlan 100
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan100
ip address 192.168.1.253 255.255.255.0
ip helper-address 192.168.1.19
!
interface Vlan200
ip address 192.168.2.2 255.255.255.0
ip access-group vlan2_access_in in
ip helper-address 192.168.1.19
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip http server
ip http secure-server
!
ip access-list extended vlan2_access_in
permit ip 192.168.2.0 0.0.0.255 192.168.2.0 0.0.0.255
deny ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255
deny ip 192.168.2.0 0.0.0.255 172.16.0.0 0.15.255.255
deny ip 192.168.2.0 0.0.0.255 10.0.0.0 0.255.255.255
permit ip any any
!

end

 

-------------------

 

HP CONFIG

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2019.01.03 09:52:53 =~=~=~=~=~=~=~=~=~=~=~=
show run
config-file-header
SBXCoreData
v2.4.0.94 / RTESLA2.4_930_181_045
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
vlan database
vlan 20,99-100,199-200
exit

bonjour interface range vlan 1
no passwords complexity enable
ip ssh server
clock timezone " " -5
!
interface vlan 99
name "Primary ISP VLAN"
!
interface vlan 100
name "Prod Data VLAN"
ip address 192.168.1.253 255.255.255.0
!
interface vlan 199
name "Backup ISP VLAN"
!
interface vlan 200
name "Guest VLAN"
ip address 192.168.2.2 255.255.255.0
!
interface GigabitEthernet1
switchport access vlan 100
!
interface GigabitEthernet2
switchport access vlan 100
!
interface GigabitEthernet3
switchport access vlan 100
!
interface GigabitEthernet4
switchport access vlan 100
!
interface GigabitEthernet5
switchport access vlan 100
!
interface GigabitEthernet6
switchport access vlan 100
!
interface GigabitEthernet7
switchport access vlan 100
!
interface GigabitEthernet8
switchport access vlan 100
!
interface GigabitEthernet9
switchport access vlan 100
!
interface GigabitEthernet10
switchport access vlan 100
!
interface GigabitEthernet11
switchport access vlan 100
!
interface GigabitEthernet12
switchport access vlan 100
!
interface GigabitEthernet13
switchport access vlan 100
!
interface GigabitEthernet14
switchport access vlan 100
!
interface GigabitEthernet15
switchport access vlan 100
!
interface GigabitEthernet16
switchport access vlan 100
!
interface GigabitEthernet17
switchport access vlan 100
!
interface GigabitEthernet18
switchport access vlan 100
!
interface GigabitEthernet19
switchport access vlan 100
!
interface GigabitEthernet20
switchport access vlan 100
!
interface GigabitEthernet21
description "Cisco Wifi Controller"
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet22
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet23
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet24
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet25
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet26
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet27
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet28
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet29
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet30
description WAP
switchport mode trunk
switchport trunk native vlan 100
switchport trunk allowed vlan remove 1-99,101-199,201-4094
!
interface GigabitEthernet31
switchport access vlan 100
!
interface GigabitEthernet32
switchport access vlan 100
!
interface GigabitEthernet33
switchport access vlan 100
!
interface GigabitEthernet34
switchport access vlan 100
!
interface GigabitEthernet35
switchport access vlan 100
!
interface GigabitEthernet36
switchport access vlan 100
!
interface GigabitEthernet37
switchport access vlan 100
!
interface GigabitEthernet38
switchport access vlan 100
!
interface GigabitEthernet39
switchport access vlan 100
!
interface GigabitEthernet40
description "Uplink to Primary ISP Router"
switchport access vlan 99
!
interface GigabitEthernet41
description "Uplink to Sonicwall X1 WAN"
switchport access vlan 99
!
interface GigabitEthernet42
description "Uplink To Edgewater WAN"
switchport access vlan 99
!
interface GigabitEthernet43
description "Uplink to Backup ISP Router"
switchport access vlan 199
!
interface GigabitEthernet44
description "Uplink To Sonicwall X2 WAN"
switchport access vlan 199
!
interface GigabitEthernet45
description "Uplink to Sonicwall X0 LAN"
switchport access vlan 100
!
interface GigabitEthernet46
description "Uplink to Sonicwall X4 DMZ"
switchport access vlan 200
!
interface GigabitEthernet48
description "Uplink to Voice Switch"
switchport access vlan 100
!
exit
ip default-gateway 192.168.1.254
SBXCoreData#

 

Interface                       new int

FastEthernet0/1                1

FastEthernet0/10             10

FastEthernet0/12             12

FastEthernet0/13             13

FastEthernet0/14             14

FastEthernet0/16             16

FastEthernet0/21             21

FastEthernet0/22             22

FastEthernet0/23             23

FastEthernet0/24             24

FastEthernet0/25             25

FastEthernet0/26             26

FastEthernet0/27             27

FastEthernet0/28             28

FastEthernet0/29             20

FastEthernet0/30             30

FastEthernet0/42             40

FastEthernet0/43             43

FastEthernet0/44             41 for 99,  44 for 199

FastEthernet0/45             45 for 100 46 for 200

FastEthernet0/47             42

FastEthernet0/48             48

 

1 REPLY 1
Highlighted
Honored Contributor

Re: Could somebody help me verify this HP switch configuration vs the Cisco source config?

Which HP Switch? there is no sign of any HP Switch.

I'm not an HPE Employee
Kudos and Accepted Solution banner