Operating System - Microsoft
cancel
Showing results for 
Search instead for 
Did you mean: 

Frequent ASR resets on Windows server 2008 on Blade servers

 
Highlighted
Super Advisor

Frequent ASR resets on Windows server 2008 on Blade servers

Hi

We have a major problem with Windows server 2008 running on Blades, they perform ASR resets at least once per day if ASR is left enabled.

My understanding of ASR is that it's supposed to reboot the system if it hangs, but here we are talking about perfectly working systems, several times with users working happily on them which are suddenly just rebooted by ASR.

My assumption here is that this is an agent problem and so we are testing out disabling ASR to verify whether we can actually get a crasched or hanging system instead of just an ASR reboot that does not produce any traceable memory dumps. So far everything seems stable when disabling ASR.

Additionally we have downgraded to ILO2 mgmt driver 1.8 since both 1.9 and 1.11 are too buggy and spam the event logs with a large number of error logs, (and always just before the ASR reboots too).

But, I wanted to check whether anyone else is seeing either of this, the ASR reboots or the ILO2 errors ? Or if anyone have any more ideas on what to check for, we're at the latest firmware on both servers and enclosures (or actually we're at mixed levels, some at the latest and some earlier just to test them all, but still no difference in behavior).

As a comparison we have no known problems when running Windows server 2008 on VMWare or on non-Blade servers, for example DL385, DL585 and so on.

8 REPLIES 8
Highlighted
Honored Contributor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

Which Firmware versions du you have on BIOS, ILO and OA?

We hade a problem with BL465c G5 mostly where we hade BIOS 2008-03-27 and ILO 1.70 with the OA 2.31.

We downgraded the ILO and the servers stopped ASR:ing. Seemed to be a problem with the new powercapping functions...
Highlighted
Super Advisor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

Thanks for the input, I'll check up on that right away. As for versions, we have several versions, enclosure firmware is all from 2.32, 2.40, 2.41 on both working and non-working systems.

Blade firmware is both the 2008 version and the new 2009.03.12 version, same here, no match as to working or not.

I've now come halfway in locating a possible source, we've downgraded the ILO 2 mgmt driver from 1.11 or 1.9 to 1.8, since both 1.11 and 1.9 produces an gigantic level of "spam" in the event logs, and right after that the servers often reboot.
In addition we've disabled the ASR on recommendation from Microsoft in order to be able to determine whether the problem is an actual system freeze (which is what the ASR should handle) or just a simple agent malfunction (which it looks like it might be since I've now had no ASR's for the past 2 days, but it's still a bit too early to tell, although I'm a little more positive now).

I have not yet tried downgrading the Insight agents, since I have servers with both the old and the new version rebooting, and if disabling the ASR solves the problem that may be a better way for us to go than downgrading. We'll just have to wait and see how this works, still any more ideas are greatly appreciated.
Highlighted
Super Advisor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

Addition: ILO firmware is 1.70.
Highlighted
Honored Contributor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

The HP support adviced us to Upgrade the servers, All bios to supported level. and then all ILO and last the OA Card.

http://h18004.www1.hp.com/products/blades/components/c-class.html#tab3_content
Highlighted
Super Advisor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

Ok, that's their usual response, however I'm a bit cautios myself on this here since as I said, the new ILO2 mgmt driver does not work very well, so I'm taking it step by step and on purpose keeping the systems on different versions so as to be able to compare effects until I find a solution to which versions to go for. :)
Highlighted
New Member

Re: Frequent ASR resets on Windows server 2008 on Blade servers

How do you disable the asr on a blade, i can't seem to find the option unless it only availible in the bios at boot.
Highlighted
Super Advisor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

If the server has done an ASR reset the ASR options are available via the SMH, if the server has not done an ASR the ASR options are usually available in the SMH but it seems rather buggy, in my case I'd say 75% of the time it's there and the rest I have to go into BIOS.

In SMH it's located under the System Config options.
Highlighted
Honored Contributor

Re: Frequent ASR resets on Windows server 2008 on Blade servers

This might be helpful:

https://forums13.itrc.hp.com/service/forums/questionanswer.do?threadId=1333579

Looks like HP is recommended rolling back three agents/drivers until the release a fix.

Nelson